Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Super Mario Galaxy 2

  1. #1
    WiiHacks Staff
    D2Sun Forum Moderator
    Only site donators may send a PM to WiiHacks Staff
    R_N_B's Avatar
    Join Date
    Dec 2009
    Posts
    272
    Thanks
    47
    Thanked 78 Times in 63 Posts

    Super Mario Galaxy 2

    Just to provide some information to those who will be buying the game and wish to use the WODE.

    Currently the game is available in the USA, that has not stopped many of us getting our hands on a copy of the new Super Mario Galaxy 2 game.

    First of all the game loads fine with the WODE. With that out of the way I am going to run through a couple of potential pitfalls and maybe provide the means to avoid any problems with the game.

    SMG2 does not appear to have any new protection, it seems that BCA has been discarded for this Super Mario game. However like NSMB it does require specific IOS to run. With NSMB those IOS were included in then Nintendo 4.1 update, once again the IOS required are contained in the latest 4.2 Nintendo update. As far as I can tell IOS056 is required. Once this is loaded or the Wii has been updated to 4.2 the game runs perfectly with a NTSC-U Wii. So in other words the SMG2 game will run and play no problem if you have a Wii with the latest 4.2U firmware.

    For those who reside on this side of the pond, and that includes all PAL users of course it is not quite as simple. The potential trap is clearly visiable to all but let me state it for the purposes of this post. Update to 4.2 and you can not play out of region games on your WODE. Do not update and you can not play SMG2. Catch 22 well almost. Of course one could just install the missing IOS - but that does require soft modding of course.

    If you have Gecko installed then it is simple to launch the game and allow via gecko the installation of IOS056. I think that priloader will do the same but that is not an area I am knowledgeable about at all. Once the IOS is loaded then you can start and play the game as per normal. If you do go the Nintendo update route you should be able to load the game and Play it via WODEflow but that I can not confirm personally at this time.

    So to recap.

    The game works perfectly with the WODE.
    4.2 Wii users do not need to do anything to get the game to work.
    4.1 Wii users have to decide if they want to update their firmware or just try and install the IOS056

    Any comments and user experiences or advice will be valued so chime in and lets enjoy gaming the WODE way.

    Tks Krank - good point.
    Last edited by R_N_B; 05-24-2010 at 11:34 AM.
    “In mathematics you don't understand things. You just get used to them.” - John von Neumann

  2. 1 User Says Thank You R_N_B For This Useful Post


  3. #2
    Senior Member Krank's Avatar
    Join Date
    Jan 2010
    Posts
    8,895
    Thanks
    953
    Thanked 4,319 Times in 2,128 Posts
    Blog Entries
    7
    I know your speaking specifically of WODES here but I think this statement is confusing

    Update to 4.2 and you can not play out of region games on your WODE. Do not update and you can not play SMG2
    Just a thought here, but could you reword that so no one gets confused. This game does not require an update to run. As you said just an updated IOS.

    (thinking of people who may be softmodded as well, that shouldn't update to 4.2)
    Damn I suck!!!!

  4. 1 User Says Thank You Krank For This Useful Post


  5. #3
    WiiHacks Staff
    D2Sun Forum Moderator
    Only site donators may send a PM to WiiHacks Staff
    R_N_B's Avatar
    Join Date
    Dec 2009
    Posts
    272
    Thanks
    47
    Thanked 78 Times in 63 Posts
    Thank you Krank - you are quite correct of course all that is needed is an IOS.

    However since the majority of WODE users (not necessarily those WODE users who are member or visit here mind you) do not soft mod nor do they want to soft mod. Let me just substantiate that claim. 20 000 + WODE units out in the world as at three weeks ago 1800 downloads of WODEflow as at time of writing this post. Less than 10% of WODE users have downloaded a application that requires soft modding so it is safe to assume that less than 10% have soft modded their Wii. I mean why softmod if you are not going to use a loader right?

    So for the bulk of the WODE users the choice is indeed between updating and not updating to be able to play the game.
    Last edited by R_N_B; 05-24-2010 at 11:39 AM.
    “In mathematics you don't understand things. You just get used to them.” - John von Neumann

  6. 1 User Says Thank You R_N_B For This Useful Post


  7. #4
    Senior Member Krank's Avatar
    Join Date
    Jan 2010
    Posts
    8,895
    Thanks
    953
    Thanked 4,319 Times in 2,128 Posts
    Blog Entries
    7
    I understand, just thought it wouldn't hurt to mention that somewhere. I get what your saying completley though!

    Thanks, RNB.

    Cheers and nice write up!
    Damn I suck!!!!

  8. #5
    WiiHacks Staff
    D2Sun Forum Moderator
    Only site donators may send a PM to WiiHacks Staff
    R_N_B's Avatar
    Join Date
    Dec 2009
    Posts
    272
    Thanks
    47
    Thanked 78 Times in 63 Posts
    I have amended the OP as it is foolish to ignore good editorial advice, especially when it makes the piece stronger. Thanks mate.
    “In mathematics you don't understand things. You just get used to them.” - John von Neumann

  9. #6
    WiiHacks Staff
    D2Sun Forum Moderator
    Only site donators may send a PM to WiiHacks Staff
    R_N_B's Avatar
    Join Date
    Dec 2009
    Posts
    272
    Thanks
    47
    Thanked 78 Times in 63 Posts
    This is to further expand on the OP thanks to atreyu187 for his help.

    One more thing there are actually two IOS56 files one will make SMG2 work if you install it the other will have no effect as it is an older version of IOS56. So if you do choose this method to get the game working the version you need is

    IOS56-64-v5405

    The one that will have no effect if you install it is version,

    IOS56-64-v4890

    Just wanted to make sure everything is clear on that one as you already have IOS56-64-V4890 installed if on system menu 4.0 or above but the other one (IOS56-64-v5405) comes from the official 4.2 update and is the needed file to boot the game from the old system menu.

    And this from Ze

    You can also install he latest IOS56 from the SMG 2 disc / backup image file. As R_N_B stated - if you do nto want to update to 4.2 system menu then you will need to soft mod (HBC) and use Gecko to install the required IOS file.

    If you have Updates: YES and Region Patch: OFF then start the HBC, Gecko and then select the game either via Fat Wode or the LCD then Launch. When you go to launch gecko will state that an IOS file is needed to be installed and you accept or reject. Accepting will install the IOS.

    “In mathematics you don't understand things. You just get used to them.” - John von Neumann

  10. #7
    WiiHacks Staff
    D2Sun Forum Moderator
    Only site donators may send a PM to WiiHacks Staff
    R_N_B's Avatar
    Join Date
    Dec 2009
    Posts
    272
    Thanks
    47
    Thanked 78 Times in 63 Posts
    This fix comes from a chap called sorg I have reproduced it here because it may offer some help or guidance to members who do wish to go that route.

    Quote Originally Posted by sorg
    I just want to warn: Update to System Menu 4.2 is the last and highly NOT recommended solution!
    4.2 doesn't add any feature. It's pure anti-piracy version. It even deletes HBC/DVDX/BootMii while installing.
    So, what you actually need is to install only required IOS without touching system menu.

    I don't know what other people here means by "Fully Softmoded". I think, they just misunderstand terms. From my point of view, fully softmoded Wii is console where every IOS has been patched to make trucha "hole" in each one and additionaly BootMii installed as boot2
    That's hardcore fully softmoded Wii. And this method absolutely not required

    So, what users need to be relatively safer than virgin Wii user:

    1) Install HBC/DVDx - 100% safe as it not involved in boot and system menu.
    2) Install cIOS as IOS249 - 100% safe as above.
    3) never install any system menu updates!!! Every system menu update installs not only new version of SM, but also tries to delete every known hack/homebrew. As result your wii won't accept older hacks to reinstall HBC if you are lucky, or even will brick if you are not so lucky. So, one more time: NEVER EVER update system menu! Use partial update to required IOS. Do NOT update IOS with x0 numbers like 30,50,60,70... These IOSes are used solely by System Menu and future update may have stubbed version os these IOSes and your wii will brick if you update x0 IOS used by your version of IOS.
    4) Use NUS to download IOS updates and WADManager to install them. Well, it's not 100% safe if you will update x0 IOS. But it's 100% safe if you update game IOS, even if it will fail.

    So, just follow these simple rules and you will be safe, and even your Wii won't be locked from some good old features.
    “In mathematics you don't understand things. You just get used to them.” - John von Neumann

  11. #8
    New Member
    Join Date
    May 2010
    Posts
    1
    Thanks
    1
    Thanked 2 Times in 1 Post

    Ca IOS56 Solution worked for me with Wii 4.1U and D2CKey.

    Quote Originally Posted by R_N_B View Post
    ... As far as I can tell IOS056 is required. Once this is loaded or the Wii has been updated to 4.2 the game runs perfectly with a NTSC-U Wii. So in other words the SMG2 game will run and play no problem if you have a Wii with the latest 4.2U firmware.
    I have a Wii with a D2CKey, System Menu 4.1U and I can confirm that the above is correct and worked for me. I have never installed an IOS file before, so this was new turf.

    Without the IOS56 update, I would get a black screen after launching the game from the disc channel. After the IOS56 update, I was able to run the game. I have not advanced far enough in the game to know if there are further pitfalls.

    For those like me who have never installed a IOS or WAD, here's the steps I followed:

    Symptom:
    Black screen after launching SMG2 from disc channel

    Problem:
    As above, IOS56-64-v5405 required to run Super Mario Galaxy 2

    Solution:
    Install IOS 56, to do so.

    1. Prerequisite: Home Brew Channel
    2. Go to http://www.qj.net/qjnet/wii/wii-homebrew-wad-manager-v14.html and download WAD manager 1.4. I tried WAD manager 1.5 but could not get it to work. On your SD Card, create a sub directory in your apps folder called Wad Manager (any name will do). Extract the WAD-Manager_v1.4 .dol file to this directory. Rename the file boot.dol
    3. Go to http://www.filecrop.com/search.php?w=iso56-64-v5405&size_i=0&size_f=1048576&engine_r=1&engine_m= 1 and download IOS56-64-v5405. On your SD card, create a sub directory call wad. In that directory extract the ios56-64-v5405.wad file from the ios56-64-v5405.rar download.
    4. From HBC channel, launch wad manager. Follow on screen prompts, accepting all defaults, to load IOS56-64-v5405


    Thanks to R_N_B for this solution.
    Last edited by Commodore64; 05-27-2010 at 02:36 PM.

  12. 2 Users Say Thank You to Commodore64 For This Useful Post


  13. #9
    New Member Moth's Avatar
    Join Date
    Feb 2010
    Location
    Oztralia
    Posts
    2
    Thanks
    20
    Thanked 0 Times in 0 Posts
    I updated my Wii (Pal) 3.1 with the waninkokos 4.1 updater

    Will the solution offered by R_N_B work to update out Will so it will play Mario Galaxy 2. My son just bought it and we're a tad sad we can't play it yet.

    Help anyone?

  14. #10
    WiiHacks Staff
    D2Sun Forum Moderator
    Only site donators may send a PM to WiiHacks Staff
    R_N_B's Avatar
    Join Date
    Dec 2009
    Posts
    272
    Thanks
    47
    Thanked 78 Times in 63 Posts
    Yes it will to the job. That will provided you with the IOS required and not oblige you to update your Wii firmware at all. The method that Commodore64 listed so helpfully in a step by step format is very simple too.

    Enjoy the game.
    “In mathematics you don't understand things. You just get used to them.” - John von Neumann

  15. 1 User Says Thank You R_N_B For This Useful Post


Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •