Results 1 to 7 of 7

Thread: update , is it safe?

  1. #1
    Junior Member
    Join Date
    May 2010
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts

    update , is it safe?

    I have wiikey is it safe to do system update because I just burnd on dvd a Red Steel 2 and when I inserted dvd in my Wii, there is an icon of system update, so my question is should I do update or not? I'm from europe and my games are all PAL.
    Thank you in front!

  2. #2
    New Member
    Join Date
    Dec 2009
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts
    what is your version now?

  3. #3
    Senior Member
    Join Date
    Sep 2009
    Posts
    4,784
    Thanks
    787
    Thanked 1,791 Times in 1,262 Posts
    Blog Entries
    5
    You should install priiloader to block disc and online updates. If you ever go to 4.2 you will lose the ability to play out of region games even with your chip.

  4. #4
    Junior Member
    Join Date
    May 2010
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts
    this one - 3.4E, what sould I do?

    do u know what update is on Red Steel 2 , and should I do update, or not? my version is 3.4E
    Last edited by oddgriffin; 05-23-2010 at 03:22 PM.

  5. #5
    Senior Member
    Join Date
    Sep 2009
    Posts
    4,784
    Thanks
    787
    Thanked 1,791 Times in 1,262 Posts
    Blog Entries
    5
    You can either check tealc's guide to make sure the update is not 4.2 (99% sure it's not off the top of my head but don't want to put you in a pickle) and accept the update if it's under 4.2, or what I would really suggest is softmod using the links in my sig tand install priiloader to block disc updates. In the future more games are going to have 4.2 (like super mario galaxy 2) and you'll either have to softmod anyways to get them to work.

    edit: keep in mind that priiloader doesn't work with 3.4 so you'd have to do the part of the guide on updating to 4.1 to install it or you'll have a world of headaches.

  6. #6
    New Member
    Join Date
    Mar 2010
    Posts
    53
    Thanks
    1
    Thanked 4 Times in 3 Posts
    Another way is use Brick Blocker to remove the update from the ISO...My Wii is 4.0E and has Argon, and that has worked for both MH3 and the new Prince of Persia

  7. 1 User Says Thank You Stom For This Useful Post


  8. #7
    Senior Member
    Join Date
    Sep 2009
    Posts
    4,784
    Thanks
    787
    Thanked 1,791 Times in 1,262 Posts
    Blog Entries
    5
    Quote Originally Posted by Stom View Post
    Another way is use Brick Blocker to remove the update from the ISO...My Wii is 4.0E and has Argon, and that has worked for both MH3 and the new Prince of Persia
    Thanks. I'm a softmod guy so I always throw out priiloader. I used brick blocker WAY back in the day.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •