Results 1 to 2 of 2

Thread: Wiikey with 1.9. Safe or not??

  1. #1
    Junior Member
    Join Date
    Aug 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy Wiikey with 1.9. Safe or not??

    1. I have a PAL wii, with a wiikey, and the 1.9 update that i pt on about a year ago. IM afraid to update my wii. Is the latest wii update going to brick my wii?

    2. Also I have got wii sports island 2, and it says i need a update toplay the game, is it safe?

    3. I have problems regularly with games not reading, is there any 'loader' or anything that would help this?

  2. #2
    New Member Median's Avatar
    Join Date
    Jun 2008
    Posts
    173
    Thanks
    0
    Thanked 36 Times in 24 Posts
    Quote Originally Posted by General Disarray View Post
    1. I have a PAL wii, with a wiikey, and the 1.9 update that i pt on about a year ago. IM afraid to update my wii. Is the latest wii update going to brick my wii?

    2. Also I have got wii sports island 2, and it says i need a update toplay the game, is it safe?

    3. I have problems regularly with games not reading, is there any 'loader' or anything that would help this?
    1. Which update? Well, should not matter, it will not brick the Wii.
    2. NTSC game? If so, no. Well, to be on the certain side never do an update from a game, download the version that matches your region instead.
    3. What discs do you use? DVD-R is recommended, and not +R, as some Wii's have problem reading them.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •