Results 1 to 9 of 9

Thread: Should I upgrade to firmware 3.4 ?

  1. #1
    Junior Member
    Join Date
    Nov 2008
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Should I upgrade to firmware 3.4 ?

    Got a Pal Wii on firmware 3.3E with Wiikey 2 and latest update 1.2
    Everything works fine except recently some backup games namely:"Need for speed undercover", "Sonic and the black knight", "Broken sword; Shadow of the templars", "Pro evolution soccer 2009" give a black screen on startup. I am reluctant to upgrade after all the issues with 3.4 posted in the forum. I have no HBC on my console and am not connected to internet.
    Need advice please

  2. #2
    Junior Member
    ~ WiiHacks ***** Supporter~
    *Priority Support Member*

    Join Date
    Nov 2008
    Posts
    180
    Thanks
    5
    Thanked 47 Times in 24 Posts
    Take your wii to a friend/work/anywhere with internet, and update to 3.4, or install IOSes 38,53,55 (you need WAD manager for that, HBC is recommended)
    A tip: don't ask details on how this is done, better go HERE and read. It's all been covered.

  3. #3
    Junior Member
    Join Date
    Nov 2008
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by danih View Post
    Take your wii to a friend/work/anywhere with internet, and update to 3.4, or install IOSes 38,53,55 (you need WAD manager for that, HBC is recommended)
    A tip: don't ask details on how this is done, better go HERE and read. It's all been covered.
    Do the games I mentioned include any update I can use?

  4. #4
    Junior Member
    ~ WiiHacks ***** Supporter~
    *Priority Support Member*

    Join Date
    Nov 2008
    Posts
    180
    Thanks
    5
    Thanked 47 Times in 24 Posts
    Yes, NFS for example. If you don't care about homebrew, just update.

  5. #5
    Junior Member
    Join Date
    Oct 2008
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by danih View Post
    Yes, NFS for example. If you don't care about homebrew, just update.
    Thanks for starting this topic.
    And thanks for the info danih...
    I'm on 3.3j (Wii Key 1 (1.9s update))
    I dont have or want homebrew on my console, so should I just update from NFS undercover? I hope it wont stop playing my backups.

    Thanks for your help!

  6. #6
    Junior Member
    Join Date
    Nov 2008
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by batti View Post
    Thanks for starting this topic.
    And thanks for the info danih...
    I'm on 3.3j (Wii Key 1 (1.9s update))
    I dont have or want homebrew on my console, so should I just update from NFS undercover? I hope it wont stop playing my backups.

    Thanks for your help!
    Right you are.
    If 3.4 is going to stop my other backup games from working, then I prefer to avoid it.
    BTW, does anyone know if Mario Kart backup works on 3.4 and Wiikey2...
    Would hate to lose that one

  7. #7
    Junior Member
    ~ WiiHacks ***** Supporter~
    *Priority Support Member*

    Join Date
    Nov 2008
    Posts
    180
    Thanks
    5
    Thanked 47 Times in 24 Posts
    Quote Originally Posted by batti View Post
    Thanks for starting this topic.
    And thanks for the info danih...
    I'm on 3.3j (Wii Key 1 (1.9s update))
    I dont have or want homebrew on my console, so should I just update from NFS undercover? I hope it wont stop playing my backups.
    Thanks for your help!
    You can update, without any worry!
    If you change your mind, you can still downgrade anytime... Just don't go 4.0 yet!

    Quote Originally Posted by mariowario007 View Post
    Right you are.
    If 3.4 is going to stop my other backup games from working, then I prefer to avoid it.
    BTW, does anyone know if Mario Kart backup works on 3.4 and Wiikey2...
    Would hate to lose that one
    It will work, that's 100% (if it's a full backup, not fakesigned)!
    Last edited by danih; 03-30-2009 at 07:03 AM.

  8. #8
    e39
    e39 is offline
    Member
    Join Date
    Dec 2008
    Posts
    1,029
    Thanks
    15
    Thanked 1,340 Times in 187 Posts
    The firmware 3.4 modified its user agreement. Nintendo can freely update your console without you permission.

    For now, the 3.3 and 3.4 firmwares are almost identical besides that.


    If you can do the HBC, the 3.3 firmware w. IOS38, 51, 53, 55 will run most of your titles.

    Helpful Threads:
    Dump & Burn discs | 3.3 / 3.4 Firmware FYI | Wii Disassemble | WiiClip Install

    Consoles:
    Wii - 4.1U - WiiKey 2 - USBLoader GX - SNES9X GX, Genesis Plus GX, FCE GX w. cover flow mods
    360 - Resident Evil S.E. - iXtreme LT 1.1 - JTag - FreeBoot 0.032 9199 Dash - NXE2GOD, XM360, XeXMenu 1.1, Flash360
    PSP - CFW 5.00m33, 16GB MSPD | DS Lite - DSTT w.1.17a r12, 8GB SDHC

  9. #9
    Junior Member
    Join Date
    Oct 2008
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks for your help guys,appreciate it!
    There's some relief in the fact that I can downgrade...so I'm gonna be thinking about upgrading to 3.4....but before that I'm gonna spend some time looking over the forums to get a hang of downgrading and HBC and all that hacking stuff!
    I'm sure I'll find useful tutorials!
    Great community!!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •