View Poll Results: Has this worked for you?

Voters
35. You may not vote on this poll
  • Yes

    32 91.43%
  • No

    3 8.57%
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: How to fix Eject Issues on Wiikey v2

  1. #1
    Junior Member
    ~ WiiHacks ★Top Post for Hardware Fix ~
    ***** Contributor
    plexo's Avatar
    Join Date
    Feb 2009
    Location
    UK
    Posts
    69
    Thanks
    1
    Thanked 11 Times in 5 Posts

    How to fix Eject Issues on Wiikey v2




    updated pic guys hope it helps a bit better
    Last edited by plexo; 02-05-2009 at 01:14 PM.

  2. 7 Users Say Thank You to plexo For This Useful Post


  3. #2
    Junior Member
    ~ WiiHacks ★Top Post for Hardware Fix ~
    ***** Contributor
    plexo's Avatar
    Join Date
    Feb 2009
    Location
    UK
    Posts
    69
    Thanks
    1
    Thanked 11 Times in 5 Posts
    updated the pics guys hope its easier to see now

  4. #3
    Junior Member
    Join Date
    Dec 2008
    Posts
    11
    Thanks
    1
    Thanked 2 Times in 2 Posts
    This is a nicer pix. My wii work better now that I did fix.

  5. #4
    Junior Member
    Join Date
    Jan 2009
    Posts
    6
    Thanks
    4
    Thanked 0 Times in 0 Posts
    I only changed the CLK point and it fixed the eject issue on my D2E drive! thanks!!

  6. #5
    Junior Member
    Join Date
    Dec 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I want to say thanks to all the guys putting forth the effort to fix fix this issue. I'am a noob to this, but I understand stuff like this. I installed my wiikey2 on a D2E drive using the wiikey2 instructions and had several eject issue and told my wife (that is just the way it is) until now. I resolider my 3.3 power points to the orignal wiikey points (like this picture) and it solved my problems. I did not change the CLK point, but I will do some for other people I install for.
    Last edited by cjva; 02-07-2009 at 10:08 AM.

  7. #6
    Junior Member
    Join Date
    Feb 2009
    Posts
    2
    Thanks
    0
    Thanked 9 Times in 2 Posts
    Hi everybody,
    First of all I don't dedicate to install or fix consoles, I just did couple of installations for my kids and some friends, recently I installed a wiikey 2 chip and started getting some eject issues. The worst part was that after I removed the chip, the wii still was having eject issues. So I suspected something was wrong with the wii itself and not with the chip. I tried some fixes as alternating ground points, shorter wires, alternate CLK signal, but nothing worked for me. I let my friend to take the wii with the eject issues and with the chip installed and ... bad news, the wii drive died after 20 minutes of playing. I got the wii back and initially I gave up and decided to order a new drive. After a while I decided to trace back on the situation and do some signal tracing with an oscilloscope. I checked every signal on the chipset D2C , included reset, power pins, reference pins, and everything was working as expected, then I checked the CLK signals located on pins 23 and 24, and voila, I found something wrong...the input signal on pin 23 (OSCI) was weak and distorted, and there was no signal on the output pin 24 (OSCO), then I notice the problem...COLD SOLDER. It was noticeable that the solder on the oscillation crystal and some pins on the D2C were darker . I resolder the crystal and pins 1 to 25 (experience has demonstrated that the cold solder appears by areas and not for specific pins), and good news the drive was back fully working, the signals on the pins 23 and 24 were well defined and with good level and defiitely no eject issues. I installed the wiikey 2 again and it worked like a charm. I installed the chip with long wires, using different grounds points always checking the signal on the OSC pins, and the signal never changed or distorted, it was really fixed.
    The explanation for the eject issues and some dead drives is not digital interference or defective chips, is just a matter of impedance. The cold solder is creating a higher impedance from the crystal to the chipset. if you use alternate ground points or alternate CLK points, you are just modifying a little bit the impedance and that makes you wii to work better. In other post have you noticed people mentioning better fixes as the ground point is connected nearer the clock sources (point C I guess is better than point A or B). Also I read some infos about wiis that worked with some specific modchips, but gave eject issues with other, again impedance, different chip vendors use different chips and that affects the loading over the oscillator circuitry.
    As I mentioned I really blame all this problem to wiis poor quality solder, i guess it is mainly due to the use of non lead solder, and that is the reason why newer consoles are more affected than older ones.


    I attached an extract of the wiikey installation guide for the wiikey 2, showing the pins I talked about. Look how the solder on the crystal is darker that in the chipset, that's what I'm talking about.

    Sorry for the long post, I hope some of you find a solid solution for your issues on this one that worked for me.
    Attached Images Attached Images

  8. 5 Users Say Thank You to jimenpa For This Useful Post


  9. #7
    Member
    Join Date
    Jan 2009
    Posts
    2,692
    Thanks
    254
    Thanked 396 Times in 369 Posts
    hi jimenpa,
    brilliant fix !

  10. #8
    Junior Member
    Join Date
    Jan 2009
    Posts
    8
    Thanks
    0
    Thanked 1 Time in 1 Post
    I took the time to look at the diference between this clock point and the one suggested by the guys at wiikey.

    Looking at them on a scope it is clear why this would improve things. This new point gives a clock of 34Mhz 3.3V p-to-p. The clock suggested by wiikey is also 34Mhz but only 2.8V p-to-p. That might be just too low at times for some wii keys.

  11. #9
    Junior Member
    Join Date
    Jan 2009
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have tried everything for the eject issue and this is the only fix that works!!! I am going to use this setup for all my wiikey2 installs from now on.

  12. #10
    Junior Member
    Join Date
    Jan 2009
    Posts
    2
    Thanks
    3
    Thanked 0 Times in 0 Posts
    this works wiikey2 d2c

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •