Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Forwarders Not Working

  1. #1
    New Member
    Join Date
    Jan 2012
    Posts
    16
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Forwarders Not Working

    Okay, I'll try to cover everything here...

    I have a Wii with 4.2U installed and had softmodded it using the old MikeandHether steps. I also had USBLoaderGX installed as a channel and had created forwarders for all my games. All was fine until I decided to update USBLoaderGX to a new version. At that point, USBLoaderGX would just not load (black screen). I had read that a cIOS needed to be updated (forget which at this point) and some time after that all of my forwarders stopped working. There was definitely a time between when I updated that cIOS and the game forwarders stopped working. During this entire time, I could not get the USBLoaderGX channel or forwarder to work (it would just return to the Wii Menu). However, I could launch USBLoaderGX fine from within the Homebrew Channel.

    Decided today to try to fix this and figured the best way was to "start" the softmod process over to make sure all everything was correct.

    I followed ShadowSonic2's steps for the softmod. When I got to the step about installing IOS236, it was not listed on my Wii. I found an install to download that and it installed without issue. I was then able to continue on with ShadowSonic2's process without issue.

    I then downloaded USBLoaderGX again and installed it, but once again, the forwarder and channel would not work. However, I could launch my games via USBLoaderGX from within HBC without issue. I found another thread that discussed that IOS58 is needed in order to load the USBLoaderGX forwarder otherwise it would just return to the Wii Menu, which is what was happening to me. I installed IOS58 without any errors. I then installed USBLoaderGX forwarder using WAD Manager 1.7 with IOS250, which I believe is what I had used in the past. The install worked, but when running the forwarder I got the "return to Wii Menu" issue. I uninstalled it and reinstalled it using IOS236. This did the trick. I could now launch the USBLoaderGX forwarder without issue and could launch my games.

    However, I still cannot get the forwarders for any of my games to work. I either get one of two errors when I launch them. Certain games get the first error and other games get the second error.

    The first error is:
    ERROR: Could not initialize USB subsystem! (ret = -6)
    The second error is an Exception error and at the bottom of the screen has a Stack Dump.

    My USB Harddrive is hooked up to the bottom USB port as I know that the other one will not work with USB drives.

    If anyone can help me out here, I would appreciate it. I am pretty technically oriented and can usually follow directions pretty well, but I know that I am missing something here and cannot figure out what it is.

    Thanks,
    Scooter
    Last edited by Scooter3176; 01-20-2012 at 09:08 AM.

  2. #2
    New Member V272846's Avatar
    Join Date
    Mar 2010
    Location
    On the outside, looking in.
    Posts
    22
    Thanks
    85
    Thanked 2 Times in 1 Post
    Did you introduce yourself?

  3. #3
    Senior Member Shift_Lock's Avatar
    Join Date
    Dec 2010
    Location
    The City of Rain
    Posts
    5,932
    Thanks
    1,320
    Thanked 1,393 Times in 1,030 Posts
    Blog Entries
    2
    I believe SS's guide might be out of date.. the any wii guide in my signature is kept up.. you can run a system check though in case Im wrong. there is also a link for that in my sig.

    Did I come off like a jerk?? Read more here


    [/spoiler]

  4. 1 User Says Thank You Shift_Lock For This Useful Post


  5. #4
    New Member
    Join Date
    Jan 2012
    Posts
    16
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Shift_Lock View Post
    I believe SS's guide might be out of date.. the any wii guide in my signature is kept up.. you can run a system check though in case Im wrong. there is also a link for that in my sig.
    I'll run the System Check when I get home tonight and will post it here. If you then think that I should go through the other softmod, I'll do that. I'd like to avoid doing the softmod process for a third time of I can avoid it.

    Thanks,
    Scooter
    Today's problems don't worry me,
    I haven't solved yesterday's yet.

  6. #5
    Senior Member Shift_Lock's Avatar
    Join Date
    Dec 2010
    Location
    The City of Rain
    Posts
    5,932
    Thanks
    1,320
    Thanked 1,393 Times in 1,030 Posts
    Blog Entries
    2
    Sometimes its the best fix and will also stop future issues from occurring.. a half or bad softmod is nothing but trouble...

    also take a look at this thread.

    http://www.wiihacks.com/general-home...tml#post635056


    It might also just be your boot.dol.
    Last edited by Shift_Lock; 01-20-2012 at 01:28 PM.

    Did I come off like a jerk?? Read more here


    [/spoiler]

  7. #6
    New Member
    Join Date
    Jan 2012
    Posts
    16
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Okay, here is my System Check...

    Spoiler


    If you wouldn't mind taking a look at it and seeing if there are any issues, I'd appreciate it. If it seems like I need to do the softmod again, let me know and I'll give that try. Was just trying to avoid having to do that if I could.

    Thanks,
    Scooter
    Today's problems don't worry me,
    I haven't solved yesterday's yet.

  8. #7
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Game Master
    cjizzle's Avatar
    Join Date
    May 2009
    Location
    Southeast Ohio
    Posts
    6,208
    Thanks
    1,450
    Thanked 2,569 Times in 1,895 Posts
    Your syscheck does show that your cIOS are a bit dated and the HBC is running on IOS61 instead of IOS58. You could update everything using the ANY Wii guide, or you could do it individually. While I'm not 100% certain as to the cause of your game forwarders not working correctly, I do know that the latest version of GX and its forwarder need HBC 1.0.7+ running on IOS58. If you want to just try fixing that, just reinstall the HBC using the hackmii installer.

  9. 1 User Says Thank You cjizzle For This Useful Post


  10. #8
    New Member
    Join Date
    Jan 2012
    Posts
    16
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by cjizzle View Post
    Your syscheck does show that your cIOS are a bit dated and the HBC is running on IOS61 instead of IOS58. You could update everything using the ANY Wii guide, or you could do it individually. While I'm not 100% certain as to the cause of your game forwarders not working correctly, I do know that the latest version of GX and its forwarder need HBC 1.0.7+ running on IOS58. If you want to just try fixing that, just reinstall the HBC using the hackmii installer.
    Okay. Thanks for the quick response. With regard to HBC on IOS61 instead of IOS58, any idea how HBC and GX are actually working then? Also, if I reinstall HBC on IOS58, does that automatically force GX to then use IOS58 as well?

    I'm guessing that it just might be easier (although longer) to run the Update Any Wii guide, huh? I'm also thinking that maybe I should try recreating the forwarders for my games since they were created when I had the older version of USBLoaderGX. Maybe there is an incompatibility?

    Thanks,
    Scooter
    Today's problems don't worry me,
    I haven't solved yesterday's yet.

  11. #9
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Game Master
    cjizzle's Avatar
    Join Date
    May 2009
    Location
    Southeast Ohio
    Posts
    6,208
    Thanks
    1,450
    Thanked 2,569 Times in 1,895 Posts
    Quote Originally Posted by Scooter3176 View Post
    I'm also thinking that maybe I should try recreating the forwarders for my games since they were created when I had the older version of USBLoaderGX. Maybe there is an incompatibility?
    That would be a safe bet. If you don't feel like messing with your mod you could try that first. If everything else is working OK then give that a shot.

    No GX would not be running on IOS58, the HBC would be. The HBC is simply a way to launch GX. I remember reading on the GX source page that the newest forwarder requires HBC 1.0.7+ and IOS58 to function correctly. If everything is working for you though, then just leave it be. Your choice.

  12. #10
    New Member
    Join Date
    Jan 2012
    Posts
    16
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by cjizzle View Post
    That would be a safe bet. If you don't feel like messing with your mod you could try that first. If everything else is working OK then give that a shot.

    No GX would not be running on IOS58, the HBC would be. The HBC is simply a way to launch GX. I remember reading on the GX source page that the newest forwarder requires HBC 1.0.7+ and IOS58 to function correctly. If everything is working for you though, then just leave it be. Your choice.
    Okay. I'll see if I can get it to work tonight after work. I am running HBC 1.0.8, although GX is not the most recent version (build 1000+ compared to build 1200+ or something like that). I had previously had been using build 700+.

    If that does not do the trick, I'll try the ANY guide and see what happens then. I assume that doing the ANY guide will correct the install of anything that is installed on the wrong IOS and also will update me to the most recent version for all cIOSs, correct?

    Thanks,
    Scooter
    Today's problems don't worry me,
    I haven't solved yesterday's yet.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •