Hello everyone, I'm not very newbie to WII, it's just that I don't quite clearly understand things about cIOS,etc..

I HAD a 4.2E WII, but then I downgraded to 4.1E because of some issues.

So I have a 4.1E WII. Softmodded (hardmodded too,but the chip is outdated so I softmodded it)
However, since I downgraded, some games gaive me Error #001 such as Sonic Unleashed and Zelda : Skyward Sword...

I meticulously followed the Guide : http://www.wiihacks.com/recommended-...d-any-wii.html

But I'm still getting this error.

Can anybody help me?? I have MMM, Priiloader, bootmii, etc installed.

I installed all recommended cIOS from the above guide, still getting this error...

Oh, btw, the guide also says to "NEVER replace cios60-v54321 with ios60-6174. Doing so will brick your wii if you update from Nintendo. Never update from Nintendo, don't MUCK up cios60-v54321."

So how am I supposed to update my WII if ever I want/need?? I have Firmware Updater 4.2 in HBC... Will it work??