Results 1 to 10 of 10

Thread: Req help with D2X Cios with regards to compatability?

  1. #1
    New Member
    Join Date
    Jan 2010
    Location
    London, England
    Posts
    213
    Thanks
    56
    Thanked 6 Times in 4 Posts

    Req help with D2X Cios with regards to compatability?

    Hi all,

    I have just recently decided to update a few of my cios's using wad manager 1.7.

    I have installed ciOS236 v65535 which I never had.

    But this is where I am a little daunted.....
    I was going to update:

    IOS249[38] (rev 17)
    IOS250 (rev 19)

    plus also install
    d2x_rev6_cIOS247[base58]-v21006
    d2x_rev6_cIOS248[base37]-v21006

    Only because after doing a syscheck 247 & 248 wasn't even listed.

    I was going to update IOS250 (rev 19) to d2x_rev6_cIOS250[57] which I don't believe will cause any adverse effects with my old games.
    but it's at this point where I am a little worried, its the update of IOS249[38] (rev 17) to cIOS249[56]-v21d2x6... I have read in a few places that it's far better to stay with the older version for compatibility sake.
    I just need to know what a few of the masters think, I.E. would it cause a major problem with many games, would it be easy to uninstall and go back to rev 17?

    Views & guidance would be very much appreciated.

    sadsack

  2. #2
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Game Master
    cjizzle's Avatar
    Join Date
    May 2009
    Location
    Southeast Ohio
    Posts
    6,254
    Thanks
    1,474
    Thanked 2,597 Times in 1,914 Posts
    Installing 249[56] d2xv6 is definitely the way to go. Has 99% compatibility for games.

  3. 1 User Says Thank You cjizzle For This Useful Post


  4. #3
    New Member
    Join Date
    Jan 2010
    Location
    London, England
    Posts
    213
    Thanks
    56
    Thanked 6 Times in 4 Posts
    I did some more reading concerning rev17, and read this here, http://www.wiihacks.com/other-faq-gu...tml#post571685

    and also read (and I wish I could remember where I read it now), but it stated that why are people being recommended to update rev17 to cIOS249[56]-v21d2x6 and then wait for all the "why has my XXX game" stopped working? .... just wish i could remember where I read it on here.
    There does seem to be some controversy concerning rev 17 and the new update for it to dx2.

    as always replies are very much appreciated.

    sadsack

  5. #4
    Senior Member Krank's Avatar
    Join Date
    Jan 2010
    Posts
    8,895
    Thanks
    953
    Thanked 4,321 Times in 2,128 Posts
    Blog Entries
    7
    There does seem to be some controversy concerning rev 17 and the new update for it to dx2.
    Not really. Rev 19, 20 and 21 replaced rev 17. d2x replaced rev 21. If you read someone saying rev 17 has better compatability for games it's not true. It has other uses but is basically not needed anymore. If you see someone that said they updated their rev 17 to something else and the games stopped working it's most often caused by them using an outdated loader that doesn't support the cIOS they are trying to use.
    Last edited by Krank; 09-10-2011 at 08:36 PM.

  6. #5
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Game Master
    cjizzle's Avatar
    Join Date
    May 2009
    Location
    Southeast Ohio
    Posts
    6,254
    Thanks
    1,474
    Thanked 2,597 Times in 1,914 Posts
    I was just typing up a response when Krank posted...lol. The only thing I had other than what he already told you was that in addition to outdated loaders, their IOS were outdated as well. It would help if you posted a syscheck and also informed us of what loader(s) you are using and their version.

  7. #6
    New Member
    Join Date
    Jan 2010
    Location
    London, England
    Posts
    213
    Thanks
    56
    Thanked 6 Times in 4 Posts
    Sorry for the noob question krank, but when you mention "outdated loader" are you referring to configurable for instance, because I use 2 sd cards for testing one with config usb v 5.2, (I know it's old but my son likes the way it works), and another with v 7.0 but I read that, that also has some major flaws, is there something in between that would give good compatibility.

    I also read that Wii Sports and Wii Play are broken in v 7.0.
    Not too sure about this one, but have the normal .dol and -222.dol been removed now?

    cheers
    sadsack

  8. #7
    Senior Member Krank's Avatar
    Join Date
    Jan 2010
    Posts
    8,895
    Thanks
    953
    Thanked 4,321 Times in 2,128 Posts
    Blog Entries
    7
    Version 70 you mean? No flaws that I am aware of and works for all my games. I mean old versions of any usb loader.

    The only thing I had other than what he already told you was that in addition to outdated loaders, their IOS were outdated as well.
    When loading from a backup loader it doesn't matter what IOS you have installed or if they are outdated as loaders use only cIOS.

  9. #8
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Game Master
    cjizzle's Avatar
    Join Date
    May 2009
    Location
    Southeast Ohio
    Posts
    6,254
    Thanks
    1,474
    Thanked 2,597 Times in 1,914 Posts
    Quote Originally Posted by Krank View Post
    When loading from a backup loader it doesn't matter what IOS you have installed or if they are outdated as loaders use only cIOS.
    I didn't state myself properly. I should have said some of them were missing IOS58 and using an older HBC from an older softmod.

  10. #9
    Senior Member Krank's Avatar
    Join Date
    Jan 2010
    Posts
    8,895
    Thanks
    953
    Thanked 4,321 Times in 2,128 Posts
    Blog Entries
    7
    That might matter with GX but no other loader uses IOS58 (and it doesn't use it to load games) and the HBC is not required at all to use a backup loader.

  11. 1 User Says Thank You Krank For This Useful Post


  12. #10
    New Member
    Join Date
    Jan 2010
    Location
    London, England
    Posts
    213
    Thanks
    56
    Thanked 6 Times in 4 Posts
    This is an updated syscheck with the few updates I did earlier: highlighted with asterisks..

    sysCheck v2.1.0b13 by Double_A and R2-D2199
    ...runs on IOS58 (rev 6175).

    Region: PAL
    System Menu 4.1E (v450)
    Priilaoder installed
    Homebrew Channel 1.0.8 running on IOS58
    Hollywood v0x11
    Console ID: 4673xxxx
    Boot2 v2
    Found 130 titles.
    Found 36 IOS on this console. 3 of them are stub.

    IOS4 (rev 3): Stub
    IOS9 (rev 516): Stub
    IOS11 (rev 10): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS12 (rev 6): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS13 (rev 10): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS14 (rev 257): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS15 (rev 257): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS17 (rev 512): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS20 (rev 12): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS21 (rev 514): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS22 (rev 772): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS28 (rev 1288): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS30 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS31 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS33 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS34 (rev 1039): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS35 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS36 (rev 1042): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS37 (rev 3612): No Patches
    IOS38 (rev 3867): No Patches
    IOS50 (rev 4889): No Patches
    IOS51 (rev 4864): Stub
    IOS53 (rev 5149): No Patches
    IOS55 (rev 5406): No Patches
    IOS56 (rev 5662): No Patches
    IOS58 (rev 6175): USB 2.0
    IOS60 (rev 6174): Trucha Bug
    IOS61 (rev 4890): No Patches
    IOS222[38] (rev 4, Info: hermes-v4.0): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223[38] (rev 4, Info: hermes-v4.0): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS236 (rev 65535): Trucha Bug, ES Identify, NAND Access -------------- ********
    IOS247[58] (rev 21006, Info: d2x-v6): Trucha Bug, NAND Access, USB 2.0 -- ****
    IOS248[37] (rev 21006, Info: d2x-v6): Trucha Bug, NAND Access, USB 2.0 -- ****
    IOS249[38] (rev 17): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS250[57] (rev 21006, Info: d2x-v6): Trucha Bug, NAND Access, USB 2.0 -- ****
    IOS254 (rev 65281): BootMii
    BC v2
    MIOS v5

    Report generated on 2011/09/11.

    Thanks for your help chaps....
    sadsack

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •