Results 1 to 6 of 6

Thread: Can't get Wii Music to work. Please help.

  1. #1
    New Member
    Join Date
    Aug 2009
    Location
    Oregon
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Can't get Wii Music to work. Please help.

    OK, I know the title looks like I probably haven't done much searching. And as this is my first post, that doubly adds to that perception. But I really have searched and searched on here, and just can't find the kind of detailed info I need. So take this post as a question (which it is), and as feedback on the forums here. Thanks.

    Here is what I have done so far. I followed the mauifrog guide to softmod my wii 4.3U. It was a while ago, but it worked completely successfully on the first try. I have cfgusb-loader running just fine. I have ripped all of my games to a fat32 HDD and they all seem to work just fine. Everything is great. Total success. Flawless. Thank you all so much! My Wii is awesome now.

    Except for Wii Music. I get the black screen immediately. Remote disconnects. Have to restart the Wii.

    So I searched and discovered that Wii Music needs IOS35-64-v1040 to solve the black screen problem. But it was really troublesome finding STEP BY STEP instructions for how to GET it, LOAD it, and INSTALL it. From what I can see, it seems to be a pretty common issue that some games need specific IOS files loaded in order to run, except there doesn't seem to be a steb by step guide on how to do that. All of the info seems to be posted all over the place. And it is hard to tell which info goes with what other info.

    So I searched some more, figured out that I needed to download NUSD. Did that, searched for how to use it. Found that. Got the wad I needed. Even found a post that said that wii music works with both v1040 and the latest version of ios35. So I downloaded both versions. But then had to keep searching in order to discover that the wads have to be put in a folder called wad, on the root of the SD card. So got that done. Almost there?

    But then how do I load the wads onto my wii? There is so much conflicting info on this. I know it is because there are a million different mods and versions that people are using, but it is very hard to figure out for a noob without a step by step guide. For example, it seems that MMM is a popular choice for loading wad files and lots of other stuff, and it comes as part of the mauifrog file downloads that I got while following that softmod guide. But for some reason it did not actually get installed on my wii as a part of that guide. I have read a lot about MMM, but can't seem to find any step by step guides for installing it on a wii (such as "download the file, unzip the file, copy the file to such and such directory on your sd card, put sd card back in wii, launch priiloader and blah blah blah"). Can't even find instructions on the mmm website, or in the readme files. That's the kind of info I need. But so much stuff seems buried in these forums under a thousand "oops I bricked my wii" posts that stuff is really hard to find. And the search options do not seem to allow me to search for phrases such as "how to install an ios using mmm". I keep getting the "word is too common" error. Even when using quotes. Maybe someone could help me use the search better?

    So anyway, I downloaded MMM, put it in my apps folder (purely a guess, since it seemed to have the same directory structure as my existing apps). Then I launched homebrew channel, and sure enough, MMM showed up there. But when I launched it, it hung at the first "loading bootmii...". So it never loaded. So I gave up on that. Maybe that's why it didn't get installed as part of the softmod install guide? Maybe my wii doesn't have boot2 or bootmii or whatever? I can't remember exactly.

    So I then turned to wadmanager. Again, there seems to be no step by step guide for installing and using wadmanager. And there seems to be a lot of differing info. Some posts say you have to load it into the SD root and rename it to boot.dol. Other posts you don't have to rename it. I tried it both ways. I even created a wadmanager folder under the apps folder and renamed the wadmanager.dol to boot.dol and copied it in there on a whim. Just wondering if it would work the same way as other apps do.

    And it did. Found it in the homebrew channel and started right up. But then when it loaded up, it asked me what ios to use. I had no idea. So I picked 249, since that was the default. Then disabled nand (no idea why, just because it was default), chose my source and loaded the wad v1040 and installed it. It gave me a success, so I exited out and tried to run wii music. No change. Still a black screen.

    So I tried the "latest version" wad, installed that, and tried again. Still no change. Then I thought, wii music is using ios 248, so maybe I need to select ios 248 in the wad manager before installing. Tried that. No change.

    So anyway, I am stuck. I have tried everything I know how to do. And have done a fair amount of guessing along the way, even though that seems really foolish given the thousands of people who seem to have bricked their wiis by guessing! :-)

    Could someone point me to a step by step guide that tells me how to install an ios to get a game to work? From the beginning. It should look something like this:

    1. Go to xyz post and find your game and the listed ios you need.
    2. Go to abc post and read the instructions for downloading and using NUSD
    3. Using NUSD, select "pack wad", then the IOS you need, then download.
    4. Create a folder on the root of your SD card called "wads" (if one does not exist) and copy the wad file there.
    5. Check to see if your wii has MMM or wadmanager installed. Here's how to check...
    6. If you have MMM, here is how to use MMM to install your new ios wad correctly.
    7. If you have Wadmanager, here is how to use wadmanager to install your new ios.
    8. If you have neither, here is how to determine which one will be best for you (what guide did you use to softmod, what version are you, what usb loader are you using, do you have bootmii or boot2, etc.)
    9. Once you have decided which is best, here is how to correctly install it on your system.
    10. Once it is installed, refer to either 6 or 7 above to see how to install your wad.
    11. Once the wad is installed, here is how to check to see if it was installed correctly, how to verify, etc,
    12. Now go to your usb loader and select the game, press 1 for options, and select the new ios you just downloaded, or change the ios to 247 or 266 or whatever, blah blah blah...

    THAT is the kind of info a noob like me needs to get all his games working correctly. I guess I was spoiled by the mauiifrog guide, because it was totally step by step, almost impossible to mess up. Very clear. If this, then that, else that kind of logical directions. VERY VERY GOOD. In fact, the sheer volume of information on these forums is incredible. I am really impressed. There are a lot of smart people on here. So it was a little disappointing to get stuck on such a seemingly common issue. I thought for sure there would be some clear instructions on what to do from beginning to end. What I found was very fragmented and confusing. A little bit here. A little more there. Put two and two together. Make a few guesses. Hope it works. If not, try again...

    Please don't see this as a diss, but more of thoughtful criticism. When a noob like me can find a post that tells them what ios they need for a game, that post should also at least point to a comprehensive guide of how to accomplish that.

    If there is such a guide, I apologize for not being able to find it, and would appreciate being pointed to it. Or else, if someone could just help me to get Wii Music running, that would be fine for now. Thanks.

  2. #2
    Member
    Retired WiiHacks Staff
    Darkcide666's Avatar
    Join Date
    Jan 2010
    Location
    Upstate NY
    Posts
    3,719
    Thanks
    560
    Thanked 924 Times in 666 Posts
    I kind of skimmed over your wall of text (TL;DR) and if you are loading off a HDD updating your IOS will do you no good. You are using your cIOS to launch the game so you can update and downgrade IOS35 all day long with no effect. That list only applies to mod chips and retail disc through the disc channel. Have you tried changing what cIOS you are using to load the game yet?
    Last edited by Darkcide666; 05-11-2011 at 03:33 AM.
    "Hackers solve problems and build things, and they believe in freedom and voluntary mutual help." - Eric S. Raymond

  3. #3
    Senior Member
    Retired WiiHacks Staff
    narse1979's Avatar
    Join Date
    Mar 2010
    Location
    Southern Fairy Land
    Posts
    7,489
    Thanks
    826
    Thanked 1,775 Times in 1,371 Posts
    Blog Entries
    7
    If you had introduced yourself you would have been given the Authors index and you would have found this http://www.wiihacks.com/submit-artic...ger-guide.html

    http://www.wiihacks.com/other-faq-gu...ger-guide.html

    Latest Channels and Ios' as Wads ---> http://www.wiihacks.com/submit-artic...nels-wads.html

    Wiihacks Guides: The Author Index
    Last edited by narse1979; 05-11-2011 at 03:44 AM.


  4. #4
    New Member
    Join Date
    Aug 2009
    Location
    Oregon
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Darkcide666 View Post
    I kind of skimmed over your wall of text (TL;DR) and if you are loading off a HDD updating your IOS will do you no good. You are using your cIOS to launch the game so you can update and downgrade IOS35 all day long with no effect. That list only applies to mod chips and retail disc through the disc channel. Have you tried changing what cIOS you are using to load the game yet?
    Yes, I think. Changing the ios or cios that runs the game was actually the first thing I tried. I found a post that said to change it to 248 (i think, not sure if I remember that right), but in mine it had two versions, one was yal and one was something else? I tried both and it didn't make a change. Then I tried all the others that were available, and none of them worked. Some wouldn't even load the game, much less get to a black screen. There were a few other settings in that post that were suggested. I tried all of them. Nothing worked. I was not aware that running from a hdd would make installing wad files useless. Not sure I understand that. But that explains why neither wadmanager nor mmm were installed in my softmod.

    Quote Originally Posted by narse1979 View Post
    If you had introduced yourself you would have been given the Authors index and you would have found this http://www.wiihacks.com/submit-artic...ger-guide.html

    http://www.wiihacks.com/other-faq-gu...ger-guide.html

    Latest Channels and Ios' as Wads ---> http://www.wiihacks.com/submit-artic...nels-wads.html

    Wiihacks Guides: The Author Index

    Thanks. I have already seen all of those posts. Plus about 50 more that are similar. I have heard of doing an introduction, but there was not a clear link during the sign up or login process or on my profile page that points to how to do that. I might have missed it. So I just filled in some personal info and thought that would be good enough. I'd be happy to do an introduction if you would be willing to tell me how to do so. Thanks.
    Last edited by narse1979; 05-12-2011 at 01:18 AM. Reason: Do not double post! Use the edit button!!!

  5. #5
    Senior Member
    Retired WiiHacks Staff
    narse1979's Avatar
    Join Date
    Mar 2010
    Location
    Southern Fairy Land
    Posts
    7,489
    Thanks
    826
    Thanked 1,775 Times in 1,371 Posts
    Blog Entries
    7
    Go to the main forum page and and look 3 sections down from the top...


  6. #6
    Member
    Retired WiiHacks Staff
    Darkcide666's Avatar
    Join Date
    Jan 2010
    Location
    Upstate NY
    Posts
    3,719
    Thanks
    560
    Thanked 924 Times in 666 Posts
    Quote Originally Posted by kinnybee View Post
    Yes, I think. Changing the ios or cios that runs the game was actually the first thing I tried. I found a post that said to change it to 248 (i think, not sure if I remember that right), but in mine it had two versions, one was yal and one was something else? I tried both and it didn't make a change. Then I tried all the others that were available, and none of them worked. Some wouldn't even load the game, much less get to a black screen. There were a few other settings in that post that were suggested. I tried all of them. Nothing worked. I was not aware that running from a hdd would make installing wad files useless. Not sure I understand that. But that explains why neither wadmanager nor mmm were installed in my softmod.
    NO! I don't think you read my post right. USB loading does not negate installing WADs. USB loading negates you IOS. Your IOS are useless when it comes to launching your game via HDD because it is using your cIOS. Updating or downgrading your IOS will do you no good unless you are using a retail disc through the disc channel or you have a mod chip and are launching backups through the disc channel. You can't have two 248s...Thats impossible. If it didn't launch with your installed cIOS you might want to re-rip the game. It could be a bad dump. As far as the introduction you just go to the introductions part of the forum and start a thread like you did here.
    "Hackers solve problems and build things, and they believe in freedom and voluntary mutual help." - Eric S. Raymond

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •