Results 1 to 10 of 10

Thread: update to 4.2

  1. #1
    New Member
    Join Date
    Dec 2009
    Posts
    70
    Thanks
    18
    Thanked 1 Time in 1 Post

    update to 4.2

    I dont really understand the new update to 4.2

    my wii is on 4.1E at the moment, will I ever HAVE to update to 4.2? im guessing games are going to come out soon that require you to do so?

    So i read the 4.2 softmod guide for wiis currently at 4.2, and i understand the 3.1 to 4.1 guide also, however, is it worth going from 4.1 to 4.2?

    im guessing that we will all have to if we want to play the latest games, will there eventually be a guide from 3.1 to 4.2?

    should i update mine to 4.2 or can i just stay 4.1 and play the latest games, im talking about endless ocean etc.

  2. #2
    Senior Member
    Join Date
    Oct 2009
    Posts
    4,219
    Thanks
    699
    Thanked 2,297 Times in 1,217 Posts
    Blog Entries
    17
    Games run off the IOS files on your console, not the system menu. Sysmenu itself functions off IOS. You only need to update specific IOS files as newer games require newer revisions.

    There's no point in updating to 4.2, it was only designed to kill homebrew. Once you're on it, it can be softmodded but requires additional steps. If you're having an issue running the new ocean game update the IOS listed on tealc's page.
    "I think that the Wii is a beautiful piece of hardware, and a broken Wii is a tragedy. It doesn’t matter why or how." -- Bushing

  3. 1 User Says Thank You Ithian For This Useful Post


  4. #3
    New Member
    Join Date
    Dec 2009
    Posts
    70
    Thanks
    18
    Thanked 1 Time in 1 Post
    forgive me if i still dont quite get it, am i right in thinking then that i can chose to never update the system menu but i have to update the IOS files to the level required to run games that would normally ask you to update the menu also? as in an update run from a disc that does both, the menu update mainly to try and mess with peoples mods, the IOS to run the game?

    ok so you mentioned "update the IOS listed on tealc's page". would this be like a further few steps that could be added on to the marvellous 3.1 to 4.1 softmod guide? do you have a link to "tealc's page?"

    if i was to buy endless ocean, when i put it in would it ask me to update even if i have turned this off on prii loader? or would it simply not work and i would then have to do what you said to remedy this.

    thanks for the help i just want this to be clear in my head. i can follow the guides but if someone was to ask me what i was doing i would not be able to tell them cause i dont understand why if you know what i mean.
    Last edited by davecambo; 02-12-2010 at 10:48 PM. Reason: missed a bit

  5. #4
    New Member
    Join Date
    Dec 2009
    Posts
    70
    Thanks
    18
    Thanked 1 Time in 1 Post
    also, you said "once your on it"

    can you safely go from 4.1 to 4.2 if your wii has been modded? i know you said there is no point and i dont want to if i dont have to, but can it be done or now that i have modded my wii is it doomed to be forever 4.1 if in the future games will have to be run off a 4.2 or above. or will it be just a case of updating the IOS to that which they require. hmm did i answer myself?

  6. #5
    Senior Member
    Join Date
    Oct 2009
    Posts
    4,219
    Thanks
    699
    Thanked 2,297 Times in 1,217 Posts
    Blog Entries
    17
    Quote Originally Posted by davecambo View Post
    forgive me if i still dont quite get it, am i right in thinking then that i can chose to never update the system menu but i have to update the IOS files to the level required to run games that would normally ask you to update the menu also? as in an update run from a disc that does both, the menu update mainly to try and mess with peoples mods, the IOS to run the game?
    Yeah that's pretty close. Think of it like this: Your console has this list of IOS revisions. A game disc has a similar list. If the numbers on your console are older than the numbers on the disc, it'll ask for an update. When you connect online with WC24 the same kind of check goes through. To prevent this from ever happening to your console, you can install an app like Priiloader and enable system hacks to prevent online and disc updates.

    Quote Originally Posted by davecambo View Post
    ok so you mentioned "update the IOS listed on tealc's page". would this be like a further few steps that could be added on to the marvellous 3.1 to 4.1 softmod guide? do you have a link to "tealc's page?"
    http://www.wiihacks.com/recommended-...s-use-run.html

    and you can find many, many useful guides from browsing around in that section.

    Quote Originally Posted by davecambo View Post
    if i was to buy endless ocean, when i put it in would it ask me to update even if i have turned this off on prii loader? or would it simply not work and i would then have to do what you said to remedy this.

    thanks for the help i just want this to be clear in my head. i can follow the guides but if someone was to ask me what i was doing i would not be able to tell them if you know what i mean.
    As long as you have block disc updates enabled, your games won't ask you to update at all. If the game black screens, that usually means an outdated IOS. Use Tealc's page as a reference to find out which one, then at the bottom of that post follow the link to NUS Downloader to get it.
    "I think that the Wii is a beautiful piece of hardware, and a broken Wii is a tragedy. It doesn’t matter why or how." -- Bushing

  7. 1 User Says Thank You Ithian For This Useful Post


  8. #6
    Senior Member
    Join Date
    Oct 2009
    Posts
    4,219
    Thanks
    699
    Thanked 2,297 Times in 1,217 Posts
    Blog Entries
    17
    Quote Originally Posted by davecambo View Post
    also, you said "once your on it"

    can you safely go from 4.1 to 4.2 if your wii has been modded? i know you said there is no point and i dont want to if i dont have to, but can it be done or now that i have modded my wii is it doomed to be forever 4.1 if in the future games will have to be run off a 4.2 or above. or will it be just a case of updating the IOS to that which they require. hmm did i answer myself?
    Here's a small cut from a guide I just wrote up that's waiting to post, this is exactly what updating to 4.2 does:

    Official/Disc Update
    • Deletes the Homebrew Channel v1.0.4 (title ID HAXX) and below
    • Deletes DVDX v1 (title ID DVDX)
    • Installs stubs (useless files with blank code) in IOS slots above 200 to prevent or remove homebrew
    • Kills region-free gaming for hardmods
    • Updates boot2 to v4, removing Bootmii in the process (can be re-installed if already supported on the console)
    • Checks for region-converted Korean Wii, if successful then the console will brick with a 003 Error
    • Updating online will bring your console to this firmware


    Notes
    This firmware was designed to kill homebrew and bears no benefit over 4.1 at all. But if you've accidentally updated to 4.2
    you'll still be able to softmod using either of the 2 guides on this site.
    "I think that the Wii is a beautiful piece of hardware, and a broken Wii is a tragedy. It doesn’t matter why or how." -- Bushing

  9. 2 Users Say Thank You to Ithian For This Useful Post


  10. #7
    New Member
    Join Date
    Dec 2009
    Posts
    70
    Thanks
    18
    Thanked 1 Time in 1 Post
    wow excellent explination there mate thanks for that. I understand now.

    yes i have priiloader installed so it wont ask me to update if i put a new game in such as endless ocean. that is what i was confused about. im guessing the worst that will happen is black screen, then i go get the IOS's i need to run the game again and im set.

    thanks for clearing that up for me you were a big help there.

  11. #8
    Member trekster's Avatar
    Join Date
    Nov 2008
    Location
    Australia
    Posts
    2,188
    Thanks
    53
    Thanked 883 Times in 404 Posts
    Blog Entries
    2
    I don't know why anyone wants to update all the time, Hell I'm still on 3.2

  12. #9
    Junior Member
    Join Date
    Feb 2010
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I just got Wii with 3.4e system menu and I think about softmod and update to 4.1 to play backup games. I am just afraid about future. So if I accidentally update to 4.2 that kill my all homebrew apps and my Wii will be virgin? Clear from priiloader, bootmii, dvdx, homebrew channel and clear IOS above 200? Is this good solution to clear Wii (for example before selling it)? Can't brick Wii?

  13. #10
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Location
    Sunny Wales, UK
    Posts
    7,152
    Thanks
    502
    Thanked 4,104 Times in 2,453 Posts
    Blog Entries
    1
    4.2 does not virginize a Wii, it just messes a few things up. There's a guide on Wiihacks that will virginize if you need it later.
    Not really doing much Wii stuff these days.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •