Hi guys, i've messed up!

Ok, first off, i'm a newbie with the Wii & i have no clue about modding them at this point. I've only found this forum after having this problem....

A couple weeks ago a friend from work said that he had a friend who could 'chip' my Wii for me so that i could play back-ups. Sounded good so a few days later i got the Wii back and true enough, it played back-ups.

For a few days all was well, then i decided to use my Wii to go online and surf the net. It wouldn't connect so i had to go into the settings to reconnect and somewhere in the process ended up clicking on 'Update System Software'!

Now in my defence, I had no idea how modding works & no-one warned me not to update. Once it started updating i had a bad feeling that i shouldn't have done that. I couldn't abort it though, and sure enough, after the update i couldn't play back-ups any longer, although it still plays originals.

Anyway, the Homebrew Channel disappeared and the 'NeoGamma' Back-up loader app no longer works. The system software is now 4.2E, I have no idea what is was before updating but I bought the Wii around September '09 and the serial No. starts with LEH23.

So, is there anyway i can get the unit back to when it was playing back-ups?
Problem is I don't know if the guy who modded it put a chip in it or not. Is there some way of telling without opening up the Wii?

I know with hindsight that i am an idiot for updating but any help would sure be appreciated! Thanks in advance for any helpful replies!

;-)