I want to use it but I see all tutorials and videos saying 4.0. Does that mean I can only use it with 4.0 and if that's what it means, can I upgrade to 4.0?

Help would be appreciated, thanks in advance.