First off alittle background,I and my brother have hard modded wii's (with a chip a local guy made himself with free source code.) works great never had a problem with it but now with the new protection in some games ie. super mario brothers wii. Iv had to make some adjustments . My system menu has always been up to date im running 4.2, iv soft modded my wii and works great now trucha disks work again so I can just get a patched SMB iso and burn. My questions are...

1. My brother is still running 3.4u because his last update was off the punch out disk. Is the trucha bug still on 3.4 and will the newest games still run on 3.4 most importantly SMB.

2. How do I insure that any game I give him has NO update on the disk even if I use one of my backup's to make an iso using imgburn and burn that iso.

I just don't wanna have to softmod his wii if i don't have to, not worth the risk cause he will never use homebrew or loader's so any help would be great.

and a side note Iv' been using Verbatims DVD +r for ever anyone else use them iv just seen alot people saying use Verbatim DVD -r should I switch?