So, I haven't really touched my Wii in about a year(not that I didn't want to) and now that New Super Mario Bros. Wii is out, I would like some guidance in helping to update my Wii to the newest possible firmware but be able to play imports, run backups, homebrew, etc. while keeping the rest legit (VC, WiiWare, etc).

I have a launch US Wii that is at 3.4U but about a year ago, in order to play Tatsunoko vs. Capcom I did some adjusting to my Wii that I have since forgotten. Everything still works fine as is, I can play backups, imports, have HBC installed, and all the regular stuff works fine no problem. I just can't play newer games, and I don't have any of the 4.0 functionality(play VC games from SD cards), so I need to do an update.

Now I haven't payed close enough attention to the Wii Scene to know what has gone on this past year and this is where some of you pros can help me out. I have little information on hand to give you and I want to have the most updated, fully homebrew usable Wii that one can have now.

Some useful information about my Wii:
3.4U
HBC 1.0.1 (IOS 36 v 4.18)
Back-Up Loader Channel installed
Canal WAD Manager by Waninkoko v 1.3 Channel installed
^(said it found Custom IOS when ran)

That's all I have at the moment. If more information is needed to help me with my cause, please tell me what else would need to be known and how I would go about doing it.

Now I'm not sure what the best route for me to go is, but if I were to guess downgrading to 3.2U then making any changes from there would be the easiest, and if that is so let me know what crucial info would need in order to follow the downgrading FAQ on this site otherwise let me hear your opinion of how I should upgrade.

Thanks for reading this and hopefully someone can help me out.