I have a wii 3.4U modded with twilight hack.
Lately I've been having a problem. Instead of the normal disc channel it says Wii System Update. I've been hearing stories of 4.2 firmware bricking and that it isn't recommended. I've ignored it for a while now. I play brawl+ so I just load the game from gecko OS. Today however, my friends with non-modded wii's would like to play with me except I cannot run vBrawl (Vanilla Brawl-Regular Brawl). I tried running it on Gecko OS with the codes turned off but it never loaded the game, just a bunch of text saying Code Dump. Then I tried using R6 back loader but it just says it "times out." I don't how else I can run it. My friend with 3.3U is currently having no problems. He does not require the wii system update to launch his game via disc channel. I have also recently bought Mario Kart wii about a month or 2 ago if that has anything to do with it. The forced update wii channel showed up just after summer I believe or around september.

I am connected to wiiconnect 24. My friend with 3.3U claims he is connected to wiiconnect24 aswell but I am not sure why I am getting this problem.

Any alternatives?
Please and thank you