hi there,
i have a korean verison of wii but modified to 4.0U. I just bought an original Band Hero (ntsc) but my wii's saying need wii system update. I've been reading in some forums that updating to 4.2 will brick my korean version wii because of ios70? please help. thanks in advance.