Results 1 to 4 of 4

Thread: Upgrade/remove softmod/preloader.

  1. #1
    Junior Member
    Join Date
    Oct 2009
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Upgrade/remove softmod/preloader.

    Ok, months ago i went through the process of HBC'ing my wii, installing SoftMii and preloader. My wii came with FW 3.1E and is now on 3.2E with SoftMii(some kind of cIOS?). I want to upgrade to 4.0E and get rid of SoftMii and preloader to replace these with BootMii, however i cannot find a guide which tells me how to remove SoftMii and Preloader while retaining the HomeBrew Channel.

    So, what i want to do in a nice list
    • Uninstall SoftMii
    • Uninstall Preloader
    • Upgrade to 4.0
    • Install BootMii
    • Keep HBC (Guides i've read remove this and just virgin-ize the wii)


    If virginizing my wii is the only way forward, how do i go about installing the Homebrew Channel again? Everything seems a bit of a pain since i installed this SoftMii thing.

    Many guides make it unclear as to whether i can just upgrade using regular update wads or whether i have to remove everything and then install stuff again.

    Any help will be appreciated, I'm completely stuck at the moment!

  2. #2
    Senior Member
    Legendary
    EMPRESS of ALL
    Retired Head Admin

    Do NOT PM for Site or Wii Issues
    Gen3SF's Avatar
    Join Date
    Jun 2009
    Location
    San Francisco
    Posts
    9,036
    Thanks
    434
    Thanked 4,658 Times in 2,237 Posts
    Blog Entries
    10
    To update your softmods, please follow this tutorial: http://www.wiihacks.com/recommended-...d-any-wii.html. As you already have HBC, just skip that part of Step 1. In Step 3, as you have an older Wii with the Trucha Bug in place, just go to Step 3D.

    The Softmii package installed a cIOS that will be overwritten in Step 3D. The standard softmod updates to 4.1, but we can get you to 4.0 via an offline FW updater. Please post in that forum when you get to Step 4. You will then install IOS60patched and THEN run an offline FW updater to get to 4.0.

    The preloader issue is a bit trickier because preloader rewrites NAND. There is a new preloader installer/uninstaller, but I don't know its reliability.

    I believe that Softmii also provided a backup loader. THe 3.1-4.1 softmod will provide NeoGammaR7, you can uninstall or keep your older backup loader as you wish.

  3. 2 Users Say Thank You to Gen3SF For This Useful Post


  4. #3
    Junior Member
    Join Date
    Oct 2009
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks very much for the quick reply!

    I read that SoftMii modifies many of the original IOS files into cIOS files and that this can be hard to remove. Does the installer in step 3D overwrite these? These are what i was having a problem with when trying to install bootmii earlier today and I've read that these will be a problem.

    If preloader isn't going to cause any problems i'll leave it there.

    Thank you very much for your help!

  5. #4
    Senior Member
    Legendary
    EMPRESS of ALL
    Retired Head Admin

    Do NOT PM for Site or Wii Issues
    Gen3SF's Avatar
    Join Date
    Jun 2009
    Location
    San Francisco
    Posts
    9,036
    Thanks
    434
    Thanked 4,658 Times in 2,237 Posts
    Blog Entries
    10
    If you have a problem with those patched IOSes, it will show up in Step 1 with a hackmii error stating no vulnerable IOS.... if that occurs, post your Wii info again in the 3/1-4.1 softmod thread so you can get some help on the steps. I, of course, hope this won't occur. Good luck. Hope I don't have to see you post a problem in the softmod thread.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •