Results 1 to 7 of 7

Thread: External hard drive randomly inaccessible

  1. #1
    New Member
    Join Date
    Jan 2013
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    External hard drive randomly inaccessible

    Code:
    HD: 500gb Seagate Freeagent Goflex USB3.0 (USB 2.0 compatible) formatted to FAT32 via Pob3008's guide. Power saving mode disabled.
    Wii: Black Wii softmodded via Mauifrogs guide. installed IOS upgrade pack and downgraded dash from 4.3u to 4.1u
    Additional Info: deleted neogamma, wiiflow, usb loader GX, and CFG loader channels. Installed usb loader GX 3.0 IOS249 and USB Loader GX - UNEO Forwarder Channel V5.1.dol to usb HDD. (I didnt like the idea of having an SD card in the slot when there is a 500gb HDD right there for storage)
    Hey everyone, I hope you guys here can point me in the right direction as to what is causing my hard drive woes. My hdd will randomly be inaccessible, as in HBC will NOT pick up any apps on the hdd... randomly. I select HBC, wait a bit for it to do its thing...nothing comes up. Exit, go back, viola, the apps on my hdd are there now. Sometimes they are there the first time, sometimes it takes a second, third, fourth, even fifth time. Same goes for my usb loader GX channel forwarder. I select it, sometimes it loads the program from my hdd, other times it kicks me back to the main wii system menu because its unable to load the actual program thats on my hdd.

    Is there an issue with my IOS249? I haven't a clue whats causing this...

    Thanks in advance,
    Homerjays

  2. #2
    Member
    WiiHacks Staff
    Moderator
    IRC AOP
    Only site donators may send a PM to WiiHacks Staff
    llaffer's Avatar
    Join Date
    May 2010
    Posts
    3,605
    Thanks
    396
    Thanked 1,121 Times in 956 Posts
    Sounds like the drive may be going to sleep due to inactivity. Check Seagate's site (or maybe someone else knows the links) to look for the config tool to change that setting in the hard drive firmware so it no longer sleeps.

    Click Below for recommended Links


  3. #3
    New Member
    Join Date
    Jan 2013
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I turned off power saving mode in seagates config utility a long time ago, still does it. Any other ideas? I have experience in modding xbox360's, but Im new to the Wii modding scene.

  4. #4
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Game Master
    cjizzle's Avatar
    Join Date
    May 2009
    Location
    Southeast Ohio
    Posts
    6,289
    Thanks
    1,488
    Thanked 2,618 Times in 1,927 Posts
    There is a fix in the d2x v9b49 cios that addresses the longer spin up time on some drives. You might want to try that route. Download this: d2x v9(beta49).zip, extract to the wad folder on your sd card, and install using your favorite wad manager.

  5. #5
    New Member
    Join Date
    Jan 2013
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by cjizzle View Post
    There is a fix in the d2x v9b49 cios that addresses the longer spin up time on some drives. You might want to try that route. Download this: d2x v9(beta49).zip, extract to the wad folder on your sd card, and install using your favorite wad manager.
    I will try that out tomorrow and get back to you guys. Even if it doesn't work, thanks guys for all the help, I really appreciate it.

    *UPDATE*

    So I installed the new wads that you supplied cjizzle, problem still persists, even worse. It's worse now because the problem still persists, and when it actually does load usb loader GX, it will fail to initialize the HDD. How is this even possible if usb loader GX itself is installed on the HDD? I'm at a loss...
    Last edited by homerjays; 01-29-2013 at 06:12 PM.

  6. #6
    Senior Member
    WiiHacks Staff
    Forum Administrator
    Only Site Donators Can PM Staff
    nightstah's Avatar
    Join Date
    Nov 2009
    Location
    Repatriated to WH
    Posts
    18,727
    Thanks
    1,893
    Thanked 4,391 Times in 3,685 Posts
    Blog Entries
    5
    Please familiarize yourself with site rules, newb

    Do not double, triple, or quadruple post. Use the edit button --- it's there for a reason, OK? Your posts have been merged...

  7. #7
    New Member
    Join Date
    Jan 2013
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    oops, accidentally deleted my last post. This was the jist of it...

    *UPDATE*

    I installed the wads that you supplied cjizzle, the problem still persists. Even worse, now when usb loader GX actually does load, it fails to initialize the hdd and will only show channels installed on the nand, no games... how is this even possible?? usb loader GX itself is installed on the hdd...

    *FURTHER UPDATE*

    I reinstalled cios v8, now gx loader works and my games are playable. The HDD problem still persists and I have a theory to why and a possible fix. Feel free to come in and correct me if I am mistaken...

    The Scenario


    -HDD pretty much always boots selected homebrew apps upon startup. (wii system menu is the default startup screen, homebrew apps are installed on the hdd with channel forwarders)
    -exiting a homebrew app (returning to wii system menu) and immediately selecting another homebrew app will almost guarantee an HDD load failure
    -after about 3-6 attempts at loading the second homebrew app, the HDD will then decide to load

    My theory

    Due to the fact that I am using a Seagate free agent ultra portable drive (only one USB connection, no external power connection), I believe that power to the USB ports is being interrupted upon exiting a homebrew app. This would cause the HDD load failures, as the HDD would actually be having to reinitialize itself every time I exited a homebrew app.

    My Solution

    Make (or buy) an adapter that would re route the HDD power to an external supply while maintaining the data connection to the Wii


    Well? It makes sense to me, I'm going to give it a shot just to see if it works.
    Last edited by homerjays; 02-01-2013 at 06:20 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •