I've been somewhat around the community awhile, but never really had to post until now. I searched for this specific issue and can't come up with anything.

Ok, to start, I have a 4.2u soft-modded Wii. I had a backup of SSBB on a USB drive that wouldn't play videos/All-star/SSE. So I assumed a bad dump. So I used Configurable USB Loader and ripped the disc myself. After ripping and playing back with IOS223-mload, it worked flawlessly. Everything worked and played. Loved it.

My USB drive is only 8GB, and SSBB takes up about 7GB of it. So I looked into SD card playability. I have a 32GB PNY Micro-SD that goes into a SanDisk SD Adapter then into the Wii. Configurable USB Loader sees the games, and even loads them (after having to install IOSX Rev19). Now, everything on SSBB plays, even videos, all gameplay, Classic, Multiplayer....Except All-Star mode.

In All-Star Mode it pits you against every character in the game. From my experience, it randomly picks the order of who you fight each time. My issue is it doesn't do this. It's the same EXACT order each time. It starts with Mr. Game and Watch, then 4 (Mario, Luigi, Peach, Bowser), then Donkey and Diddy, then Ice Climbers, and ROB. When I step on the platform to enter the fight for ROB, it freezes. I tried other characters, difficulties, and even loading ROB to play with, and it all works. But I can't for the life of me figure out why it works on USB, but on SD All-Star doesn't. I'm so confused as to where to even begin looking for what the problem may be. (I'm using IOS223-mload to boot the game).