Right been at it for several hours now... and can't find the problem. At the moment I cannot select/change themes and languages in WiiFlow. In the settings screen they are both set to default and clicking on the side arrows does not change it to anything else.

Here's all I've tried and done.
- I have tried a few different versions (at least I think so, did at least two, since I also tried the one from the Google SOurce site. Hard to find which is the most recent version and where to get it anway).
- I have made sure that theme folders and .ini files are inside the themes folder
- I have made sure there is a language.ini and even a folder called Languages with all language .ini files in it.
- Tried modifying the wiiflow.ini file because in the faq it said to change the line for "data_on_usb" to no in case of SD (as mentioned in the FAQ of one of the versions I tried). The line wasn't even in the .ini so I added it.

All of the above and combinations of it havent'worked so far and I'm a bit at a loss now. Apart from the language and themes, everything seems to work fine, playing games etc or other options in the menu, just the themes and languages messing with me.

Can anyone help me with some good advice. Or direct me to a good working version of the latest WiiFlow (since I still have doubts I am using the most recent version). All the ones at the 'official' Google page are deprecated... SO what is the most current version?
Also, can you use a .dol file of an older version with a newer version of WiiFLow? One remark at the Google Source site led me to believe that, since for RC2.2 it said 'just add a .DOL'.