Results 1 to 8 of 8

Thread: USB Loader GX crashes on Kirby's Return to Dreamland at main menu

  1. #1
    New Member
    Join Date
    May 2012
    Location
    Troll Land
    Posts
    14
    Thanks
    2
    Thanked 3 Times in 3 Posts

    USB Loader GX crashes on Kirby's Return to Dreamland at main menu

    I know there have been lots of threads on this topic (here as well as on other sites) but most are old and recommend outdated stuff so I thought I should make a new one.

    I am using USB Loader GX 3.0 with cIos d2x v9 beta r49 installed and Kirby's Return to Dreamland crashes every time (even with cIos d2x v8 final) after the "Press 2 to Continue" screen (White screen and no sound requiring a hard power off). I have tried d2x cIos v7, v8, and v9 beta r49 and they all have the same result. It works perfectly on WiiFlow and CFG USB Loader but I am in love with GX and no matter what loader or theme I try, I can't stop coming back to GX's awesome channel feature that looks like the Wii system menu (because many of my WiiWare and VC titles either don't have cover art or don't have any GOOD full box cover art) and the fact that on the "usb loader releases wiki" (just google that string and it will be the first result) page, GX supports ALL features as well as loading more than 512MB of nand channels from Emu Nand (I have about 1.2GB sized Emu Nand) with unlimited pages.

    Back on topic: Is there any way to get this working?

    BTW I am using a WBFS partition (used to have NTFS) and a direct rip off of my disk (yes I have tried re-ripping with other loaders{CFG USB Loader, and WiiFlow})

  2. #2
    Retired Staffer bmarlo's Avatar
    Join Date
    Nov 2009
    Location
    Sydney,Australia
    Posts
    5,945
    Thanks
    977
    Thanked 1,702 Times in 1,315 Posts
    Blog Entries
    4
    Does the cIOS you're loading the game with have a base of [56]?
    Kirby works fine for me with cIOS 249 d2x-v8 [56] final, and GX 3.0



  3. #3
    New Member
    Join Date
    May 2012
    Location
    Troll Land
    Posts
    14
    Thanks
    2
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by bmarlo View Post
    Does the cIOS you're loading the game with have a base of [56]?
    Kirby works fine for me with cIOS 249 d2x-v8 [56] final, and GX 3.0
    When installing with the d2x cios installer no matter what options I choose it says "installing d2x v6 base 37 rev21006 to slot 249" why is it doing that?

    EDIT: Ok, it installed correctly gimme a minute to test.

    EDIT 2: Same result want me to post a sys check to make sure it installed right?

    EDIT 3: I checked ios 249 and it says "IOS249[37] (rev 21006, Info: d2x-v6): Trucha Bug, NAND Access, USB 2.0"

    Why is d2x cios installer not installing properly? I changed options to "cIos d2x-v8 final, Base 56, and slot 249" then pressed A, moved the blinking cursor to slot 249 and pressed a but it still only installs d2x-v6. WHY DOES MY Wii HATE ME!?!?!? Do you need a full one?
    Last edited by loismustdie555; 05-29-2012 at 05:39 PM.

  4. #4
    Retired Staffer bmarlo's Avatar
    Join Date
    Nov 2009
    Location
    Sydney,Australia
    Posts
    5,945
    Thanks
    977
    Thanked 1,702 Times in 1,315 Posts
    Blog Entries
    4
    Quote Originally Posted by loismustdie555 View Post
    EDIT 2: Same result want me to post a sys check to make sure it installed right?
    Yep. Give us a look.



  5. #5
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Game Master
    cjizzle's Avatar
    Join Date
    May 2009
    Location
    Southeast Ohio
    Posts
    6,135
    Thanks
    1,430
    Thanked 2,521 Times in 1,862 Posts
    The installer won't work if the d2x v8 folder isn't properly set up and/or the cIOSmaps file is messed up. Alternatively you could just install all the wads using MMM, WiiMod, or Wad Manager 1.7. HERE is a link to the wads.

    Obviously do what bmarlo said first and post your syscheck to verify

    EDIT: Also, when you attempted to install it did you make sure the revision was 21008? If not it should be.

  6. 1 User Says Thank You cjizzle For This Useful Post


  7. #6
    New Member
    Join Date
    May 2012
    Location
    Troll Land
    Posts
    14
    Thanks
    2
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by cjizzle View Post
    The installer won't work if the d2x v8 folder isn't properly set up and/or the cIOSmaps file is messed up. Alternatively you could just install all the wads using MMM, WiiMod, or Wad Manager 1.7. HERE is a link to the wads.

    Obviously do what bmarlo said first and post your syscheck to verify
    Ok, gimme a minute.

    EDIT: I think I already installed the wads at some point...

    EDIT 2: Here you go;

    Spoiler

    Last edited by bmarlo; 05-29-2012 at 05:56 PM. Reason: Added spoiler to syscheck.

  8. #7
    Retired Staffer bmarlo's Avatar
    Join Date
    Nov 2009
    Location
    Sydney,Australia
    Posts
    5,945
    Thanks
    977
    Thanked 1,702 Times in 1,315 Posts
    Blog Entries
    4
    IOS249 has a base of [37]. Try IOS244, or as cjizzle said, install the IOS249 wad instead of using the installer.



  9. 1 User Says Thank You bmarlo For This Useful Post


  10. #8
    New Member
    Join Date
    May 2012
    Location
    Troll Land
    Posts
    14
    Thanks
    2
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by bmarlo View Post
    IOS249 has a base of [37]. Try IOS244, or as cjizzle said, install the IOS249 wad instead of using the installer.
    Tried both still does not work.

    I really want to on my wii right now.

    EDIT: WOOT!!! Changed settings from "Force 16:9" to default and it worked. THANK YOU cjizzle!!

    EDIT 2: D@mnit! I get a black screen after beating the 3rd boss (big fish guy)

    EDIT 3: Oops, almost forgot. Thank you bmarlo!
    Last edited by loismustdie555; 05-30-2012 at 12:38 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •