Results 1 to 10 of 10

Thread: Need help with identifying modchip

  1. #1
    Junior Member
    Join Date
    Aug 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Need help with identifying modchip

    Hey all, just got my JP Wii modded by a game shop for around 75 dollars (yeah, feels like I've been ripped off). The problem now is that I don't know exactly which mod chip my Wii currently has. Here are some clues that I've gathered.

    I tried asking the person who modded it for me, but he doesn't seem to have any clue himself. He kept saying that its called D2C, which probably isn't the name of that mod chip, but the name of the chipset I have.

    He also claims that some US version games (like the US version of Mario Galaxy) wont work on my JP Wii, while it works fine with all JP version games. He also said to be able to play all US games, I'll have to format my wii and reinstall it as an US system to be able to play all US games (and some JP games).

    So currently, I think its likely that I have a D2CKey mod chip, since I'm using the D2C chipset. But is there anyway to make sure? Also, is it true that I'll have to reformat to a US system to be able to play all US games? Does that happen for better modchips like D2Pro9 as well?

  2. #2
    Member
    Retired Staff Member

    Join Date
    Jun 2008
    Posts
    1,494
    Thanks
    70
    Thanked 230 Times in 116 Posts
    Wow, after spending money and the installer doesn't know which chip he installed, that is crazy.

    The way to find out if your wii is D2C is determined partly with the serial number and the date of purchase. I don't know of any well known chip that has trouble with MG game. The newer chips all play all region games so even though there is now a method to change the region of a Wii its not really necessary or advisable.

    The surest way to determine the mod chip is to open up your Wii and see it and also take pics just in case you need to post it here.

  3. #3
    Junior Member
    Join Date
    Aug 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    thanks for the reply,

    i wish i could open up my wii, but i dont have the right screwdrivers to do it (other wise I would've installed the mod chip myself). but I'm 100% sure my wii uses a D2C chipset though.

    another problem I have in mind is, that the modder stated that I should not update my wii filmware with newer US games. Can someone explain what the whole updating deal is about? and what happens if I did do a US update? and is it possible to continue playing newer games if I dont update my wii?

    also, for some reason, i now have two weather and two news channels in my wii dashboard, is there anyway to get rid of it?

    sorry about all these questions.. its just that I'm not really impressed with my modded wii, especially after spending 75 dollars on it.

  4. #4
    Member
    Retired Staff Member

    Join Date
    Jun 2008
    Posts
    1,494
    Thanks
    70
    Thanked 230 Times in 116 Posts
    You should never update Wii using a game that is from a different region than your Wii. So if your Wii is NTSC-J (JP) then only update using JP games, don't update from USA or PAL games. It will Brick your Wii.

    If you are unable to access the Wii Settings then you may have Semi-Bricked your Wii. Here is a link explaining Semi-Bricked

    Semi-bricked Wii: What is it and how to unbrick it? Games and Gadgets: How I see them.

    IF needed, Here is link for fixing Semi-bricked wii - Make sure you download the correct file for your Wii

    Semi-brick fix discs for all three regions (updated)

    Here is link to fix duplicate channels


    Wii Duplicated Channel Remover v2 Released - DCEmu Forums:: The Homebrew & Gaming Network :: PSP Dreamcast Nintendo DS Wii GP2X Xbox 360 GBA Gamecube PS2 Apple iPhone Forums

  5. #5
    Junior Member
    Join Date
    Aug 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    thanks again for your reply jbloggs.

    i could still access the Wii Settings, so i guess i hadnt broken anything yet.

    so is updating the wii neccessary for playing newer games?

    if so, are there other ways of updating the wii other then getting it from nintendo games? i only play US games (which is why i modded my JP wii), so does that mean I'll have to get JP games just to update it?

    and does duplicate channels cause any other problems? I'm a little afraid of messing with my Wii so if its not neccessary, i wouldnt want to try hacking it, even if its just using homebrew softwares...

  6. #6
    Member
    Retired Staff Member

    Join Date
    Jun 2008
    Posts
    1,494
    Thanks
    70
    Thanked 230 Times in 116 Posts
    Currently there are no games that specifically require the 3.3 firmware. So you can use Wiu1.1 (search forum for this) to remove the updates from the game iso and at the same time you can region patch it to NTSC-U although this is not necessary for the new modchips but it doesn't hurt.

    It is always safer to do wii updates via the Wii settings menu.

  7. #7
    New Member
    Join Date
    Jul 2008
    Posts
    24
    Thanks
    5
    Thanked 14 Times in 5 Posts
    Top spin 3 requires the 3.3 as far as I know as it did not work until I upgraded to 3.3

  8. #8
    Member
    Retired Staff Member

    Join Date
    Jun 2008
    Posts
    1,494
    Thanks
    70
    Thanked 230 Times in 116 Posts
    I've seen Top Spin 3 being played on a 3.2U Wii.

  9. #9
    Junior Member
    Join Date
    Dec 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The link for the wii menu USA doesnt work can you please help me thanls..

  10. #10
    Senior Member
    Retired Staff
    davepm's Avatar
    Join Date
    Aug 2009
    Location
    Lincoln, Lincolnshire, United Kingdom
    Posts
    4,561
    Thanks
    124
    Thanked 2,059 Times in 831 Posts
    Blog Entries
    1
    Quote Originally Posted by bacon1 View Post
    The link for the wii menu USA doesnt work can you please help me thanls..
    probably because this thread is over 1 YEAR OLD!

    use the forum search and dont bump ancient threads.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •