Results 1 to 6 of 6

Thread: D2Pro chip gone bad? Or is it the dvd drive?

  1. #1
    New Member
    Join Date
    Jan 2009
    Posts
    14
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Question D2Pro chip gone bad? Or is it the dvd drive?

    Hi all,

    My wii had a D2Pro chip (v1.7 firmware) and I have it softmodded as well. I have firmware version 4.1 installed. Worked great for at least 2 years now, until...

    Yesterday I was playing grand slam tennis and while playing the game I got a 'can't read disc' error. I restarted the wii but after that it wouldn't read any game anymore, no originals and no backups.

    I took the wii apart and cleaned the dvd lens. Made no difference.

    Used some contact cleaner on some connectors and also on the wii chip. Made no difference.

    I then took off the D2Pro chip (I have it connected with a Wii clip). Then I could start some games again but not all want to load. Perhaps it's not region free anymore now and it doesn't want to load NTSC games? Although I though with the softmod it is region free as well?

    Is there any way to check if the D2Pro chip has gone bad? Or any way to check if the dvd drive has gone bad?

    I'd like to keep using the modchip as games will load faster than with softmod.. so any way to check and know for sure where the fault is?

    Thanks.

    Steven
    Last edited by BluPhant; 04-23-2012 at 06:32 AM. Reason: doublepost

  2. #2
    Forum Administrator BluPhant's Avatar
    Join Date
    May 2010
    Location
    New England
    Posts
    2,350
    Thanks
    206
    Thanked 1,276 Times in 720 Posts
    I can tell you this - I have a D2Pro9 V3 Modchip that I installed years ago (soldered in). Softmoding did not affect this in any way. For softmods, region free for disc loading would either be accomplished using Neogamma, or if you have modchip still in, you could set priiloader to be region-free.

    My opinion, and my bet would be that the drive is starting to go. It happens.

    And my standard answer: Discs as a medium stink. USB loading ftw.

    -Blu

    Softmod ANY Wii
    | USB-FAT32 | Error Index | Chat!
    An Introduction To Wii Hacking - MUST READ for all new Wii Hackers
    If I have been of help to you, please click the "Thanks" icon to the left.



  3. #3
    New Member
    Join Date
    Jan 2009
    Posts
    14
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Hey Blu, thanks for the reply. I have preloader (v0.29) set for region free and I am using neogamma. Still some discs won't load.. and with the d2pro chip installed nothing loads anymore. I guess it's the disc drive... still strange though that without the d2pro some games do work.

    Perhaps I'll buy a new laser and check if that'll fix it.. or I'll look into USB loading. ;-)

  4. #4
    Forum Administrator BluPhant's Avatar
    Join Date
    May 2010
    Location
    New England
    Posts
    2,350
    Thanks
    206
    Thanked 1,276 Times in 720 Posts
    Not for nothing, but you should consider updating your softmod. Priiloader has come quite a way since that version. You can use the tutorial in my signature. Use the homebrew channel installed option.

    This way youre on known best configuration. Good luck!

    -blu

    Sent from my DROID X2 using WiiHacks

    Softmod ANY Wii
    | USB-FAT32 | Error Index | Chat!
    An Introduction To Wii Hacking - MUST READ for all new Wii Hackers
    If I have been of help to you, please click the "Thanks" icon to the left.



  5. #5
    New Member
    Join Date
    Jan 2009
    Posts
    14
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Hey Blu, I was already working on updating my softmod from the guide in your signature before you mentioned it. ;-) I finished it today, and without the modchip installed it seems to load every dvd again, so that's good news. Also USB loading from my HDD work great as well, even though the drive is NTFS it works without issues. great! I guess the problem was in the modchip after all..

  6. #6
    New Member
    Join Date
    Jan 2009
    Posts
    14
    Thanks
    5
    Thanked 0 Times in 0 Posts
    small update: turns out my wii stil doesn't load all games. new laser is on the way...

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •