Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Wii Fit Plus requires disc update despite up-to-date IOSes

  1. #1
    Junior Member
    Join Date
    Dec 2009
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Wii Fit Plus requires disc update despite up-to-date IOSes

    I have IOS53 (Which Wii Fit is supposed to need to run) and IOS70 (supposed to be the most recent IOS, since i just got Wii Fit Plus at Christmas and do not know how old the disc itself is). The Disc Channel, with Wii Fit Plus, still has the Disc Update requirement message and screens. Is there another IOS that Wii Fit Plus requires, or is it more likely a separate issue (possibly related to the complaint had by the Silent Hill: Shattered Memories owner in another thread)?

    I could probably just use Priiloader, but I would really prefer to exhaust all more reasonable possibilities, or (if possible) fix the problem itself rather than skipping over it.

    I doubt it's relevant, but I was able to use the basic Wii Fit game since I first softmodded the console (but before adding things like Homebrew channel, it still works though), and it doesn't count the Wii Fit Plus disc yet to allow access to the Training section (and, I assume, the Body Test section) on the Wii Fit menu. It's probably because I haven't been able to install the game itself, being unable to load the disc without the updates or whatever else I need to do, but just in case it's relevant...

    So, does anyone know what the issue is, and hopefully how to fix it?

  2. #2
    Banned
    Join Date
    Dec 2009
    Posts
    5
    Thanks
    5
    Thanked 0 Times in 0 Posts
    does it work if you disable disk updates?
    -Josh.

  3. #3
    Junior Member
    Join Date
    Dec 2009
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Do you mean a preloader or something like the delete-update-from-disc program that was floating around somewhere, or do you mean something different? Because I don't know how to deactivate the disc updates through "normal" means (assuming there is a built-in "no disc updates" option), and when I do a google search for phrases like "how to disable disc updates wii" the only thing that shows up are dozens of homebrew sites saying not to update (variations include changing the order o the words Wii, disc, and update, using the term "updates from disc" which should just narrow the search anyway, and using "deactivate" instead of "disable". Using quotes [specifically around "update from disc"] just turned up a bunch of preloaders).

    I can use a preloader as an absolute last resort, but I intend not to not use a backup player now or ever and I'm not using any shady "delete update-related stuff off the disc" program.

  4. #4
    Junior Member
    Join Date
    Dec 2009
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I'm sorry for the double post, but it's been five days, the person who responded has not answered the question directed to them, the thread is halfway down the second page, and new information has come up.

    It turns out that Priiloader is not an option, since the WiiBrew page for it says preloaders are not to be used for Wiis with modified IOSes. I don;t have any of the weird IOSes like the one DOP-IOS requires, but I have used DOP-IOS MOD and WiiSCU for IOSes so Priiloader seems like it won't be an acceptable choice.

    So does anyone have any idea what the problem is, even hearsay? If the "requires update from disc despite necessary IOSes" problem has happened (and especially if it has been solved), or if anyone knows what IOSes WiiFit Plus carries aside from the one it uses, that would be a good place to start.

  5. #5
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Location
    Sunny Wales, UK
    Posts
    7,152
    Thanks
    502
    Thanked 4,104 Times in 2,453 Posts
    Blog Entries
    1
    Open the WiiFitPlus ISO in Wiiscrubber, expand the relevant Update section and peruse the IOS contained therein. Priiloader worked fine on my modified Wii, I have a few IOS that are modified with Trucha and what not and it worked just fine. If it is not happy with your IOS then it'll tell you when you install anyway. I think I needed to DOP my IOS36, but I laugh in the face of danger because I know what's safe and what's not, plus I have boot2, huzzah.
    Not really doing much Wii stuff these days.

  6. #6
    Junior Member
    Join Date
    Dec 2009
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you, Teal'c. I will see about using WiiScrubber to find the IOS list on the disc and report back if there are no IOSes I don;t have on the Wii, if I add the necessary IOSes and that does not solve the problem, or to report the problem as solved with what solved it.

    P.S.: There was a typographical error in my previous post where I meant to say "has happened with another game". It shouldn;t be necessary, but if anyone does know...
    Last edited by JET73L; 01-04-2010 at 01:07 PM.

  7. #7
    Junior Member
    Join Date
    May 2009
    Posts
    12
    Thanks
    0
    Thanked 1 Time in 1 Post
    You can use your Loader program and it should work fine. I have 3.4u and I play an original fit plus through the loader with no issues

  8. #8
    Junior Member
    Join Date
    Dec 2009
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Well, this is troublesome. Since Priiloader doesn't work on System Menu v.353, and I have found nothing useful from Wiiscrubber, I despair of ever getting WiiFit Plus to work.

  9. #9
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Location
    Sunny Wales, UK
    Posts
    7,152
    Thanks
    502
    Thanked 4,104 Times in 2,453 Posts
    Blog Entries
    1
    That's a rather defeatist attitude. Update your Wii to 4.1 using firmware updater, install priiloader, block updates, run the game from wherever you like.

    3.3 is a bit pointless these days.

    Or just let the disc update you to 3.4. What will you lose? Not much.
    Not really doing much Wii stuff these days.

  10. #10
    Junior Member Jasons34's Avatar
    Join Date
    May 2009
    Posts
    1,295
    Thanks
    20
    Thanked 455 Times in 350 Posts
    Blog Entries
    1
    Im too lazy to update my wii from 3.2 to whatever simply for the fact that I would need to reinstall some programs. I have hundreds of games; old ones, newest ones, and out or region ones and they all work on my firmware. I look at it this way.... as long as all my games work along with the other stuff I have on it, then theres no need for me to upgrade.
    If I have helped you in any way, please thank me by pressing the little thanks button.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •