Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: Question about Firmware versions

  1. #1
    Junior Member
    Join Date
    Nov 2009
    Posts
    6
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Question Question about Firmware versions

    I'll be getting a Wii on Monday and I haven't used the machine much before, have read trough major softmodding tutorials on here, but wondering if it's best to upgrade to 4.2 BEFORE any mod attempt or if there is an optimal firmware to mod the Wii at while benefiting from the newest releases.

    Thanks.

    This is my first post, I'll hopefully detail my journey on this forum. Cheers.

  2. #2
    Junior Member
    Join Date
    Jan 2009
    Location
    Australia
    Posts
    21
    Thanks
    2
    Thanked 6 Times in 4 Posts

    Smile

    Safe 4.2 upgrade any wii console GUIDE. This is a modification of the Shop Channel and IOS61 Installer by tona. It has been rigorously tested and should not brick anyone, but as usual, use it at your own risk.

    It will detect your region, download and install all of the NECESSARY IOSes, your specific system menu, and the shopping channel update from v4.2 It will NOT touch your cIOSes, stub anything, or touch your boot2. It also will NOT trucha sign any of the IOSes it downloads and installs. If you want to pirate, you'll have to go ahead and use DOP-IOS or similar to trucha patch your IOS70 after the upgrade is complete

    It is almost completely automated. Answer a question in the beginning, sit back and relax, and wait for the update to be completed. When finished, you'll be on v4.2 with everything functional (no upside down HBC, no "vulnerable IOS not found" errors). This should hopefully eliminate all of the goofy issues people have been having with the upgrade.


    What you should install first
    •Homebrew Channel
    ◦Ensure this is updated to the most recent version.
    •IOS249
    What you need
    •SD Card
    •Wii connected to the Internet.
    What to download
    •v4.2 Safe Firmware Upgrader from MEGAUPLOAD - The leading online storage and file delivery service

    1.If you have not done so recently, make a back up with BootMii before attempting this.

    2.Use the Wii Data Management screen to check you have at least 250 blocks of free space left. Delete unneeded channels or saves until you do.

    3.Remove all GameCube memory cards and controllers.
    ◦This step is very important. Do not ignore it .

    4.Unrar V4.2 Safe Firmware Updater.rar and copy the contents of the apps folder to sd:/apps.

    5.Start the Homebrew Channel and run v4.2 Safe Updater.

    6.Read the message and push A to accept.

    7.Check that the installer has detected the correct region for your Wii. Push
    A to accept.
    ◦If you install an update from the wrong region, it will brick your Wii, so be careful here

    8.The tool will automatically download and install the needed IOSes.

    9.When the tool completes you will be on Firmware 4.2. Push A to exit when prompted.
    ◦If the tool does not ask you to push A to exit after the installation, it means one of the downloads crashed. You will need to run it again.

  3. 1 User Says Thank You Andy9702 For This Useful Post


  4. #3
    Junior Member
    Join Date
    Nov 2009
    Posts
    6
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Thanks Andy,

    Is there a specific firmware I should start w/ or are any of them good?

  5. #4
    Junior Member
    Join Date
    Jan 2009
    Location
    Australia
    Posts
    21
    Thanks
    2
    Thanked 6 Times in 4 Posts
    For now any firmware will do, if you start of with 4.0 it will be easy to softmod and will take up to 10-18 minutes to mod. But if you start off with 4.1 or 4.2 well just be prepared to spend more than an hour softmoding you Wii, you'll still be able to softmodd it but it will be harder and probably allot longer too. Just PM me if you have any other questions.

  6. 1 User Says Thank You Andy9702 For This Useful Post


  7. #5
    Senior Member
    Retired Staff
    davepm's Avatar
    Join Date
    Aug 2009
    Location
    Lincoln, Lincolnshire, United Kingdom
    Posts
    4,561
    Thanks
    124
    Thanked 2,059 Times in 831 Posts
    Blog Entries
    1
    i would seriously recommend you ignore the guy above, who obviously has no idea....

    You do NOT want to install 4.2

    4.2 has no benefit over 4.1. Update to 4.1, which adds some useful new features, but the entire purpose of the 4.2 update was to kill homebrew.

    Yes, 4.2 is moddable, buy why make things harder for yourself than you need to?

    follow the guide linked in my sig (the 3.1-4.1 softmod guide), this will softmod your wii and update you to 4.1.

  8. 1 User Says Thank You davepm For This Useful Post


  9. #6
    Junior Member
    Join Date
    Nov 2009
    Posts
    6
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Thanks guys, enlightening info. Sounds like there are no software benefits of 4.2 so, as I expect, the Wii will be 4.1 or earlier.

    Looking forward to tracking my journey. I have the Wii usb HDD ready and SD cards up and everything.

    Glory times

  10. #7
    Junior Member
    Join Date
    Jan 2009
    Location
    Australia
    Posts
    21
    Thanks
    2
    Thanked 6 Times in 4 Posts
    Davepm, you must be really inexperienced at softmoding Wii's the benifit of safe upgrading to 4.2 is that all YOU DARN GAMES WORK and you can access the shop channel !! daah thats why, for E.g. if your on 3.2 and you wanna play Super Smash Bros. Brawl you have to install the update. with would probably semi brick your Wii. Safe upgrading is the best option.

  11. #8
    Senior Member
    Retired Staff
    davepm's Avatar
    Join Date
    Aug 2009
    Location
    Lincoln, Lincolnshire, United Kingdom
    Posts
    4,561
    Thanks
    124
    Thanked 2,059 Times in 831 Posts
    Blog Entries
    1
    Quote Originally Posted by Andy9702 View Post
    Davepm, you must be really inexperienced at softmoding Wii's the benifit of safe upgrading to 4.2 is that all YOU DARN GAMES WORK and you can access the shop channel !! daah thats why, for E.g. if your on 3.2 and you wanna play Super Smash Bros. Brawl you have to install the update. with would probably semi brick your Wii. Safe upgrading is the best option.
    It amazes me how many people think you have to update your system menu to play games.

    I had my Wii at 3.2 when i bought and modded it. I didnt update it. I never had a single game that wouldnt play.

    Im now at 4.1, which i needed as i wanted to use an SDHC card. Again, ALL of my games work.

    NO game requires any specific System menu, Each game requires a particular IOS to run, which can be installed via wad manager.

    SSBB will run fine on 3.2.

    I would suggest that you get your own facts correct before making any comments about other peoples ability and knowledge, or all that happens is that YOU end up looking like an inexperienced, unknowledgeable idiot.

  12. #9
    Junior Member
    Join Date
    Jan 2009
    Location
    Australia
    Posts
    21
    Thanks
    2
    Thanked 6 Times in 4 Posts
    Quote Originally Posted by davepm View Post
    It amazes me how many people think you have to update your system menu to play games.

    I had my Wii at 3.2 when i bought and modded it. I didnt update it. I never had a single game that wouldnt play.

    Im now at 4.1, which i needed as i wanted to use an SDHC card. Again, ALL of my games work.

    NO game requires any specific System menu, Each game requires a particular IOS to run, which can be installed via wad manager.

    SSBB will run fine on 3.2.

    I would suggest that you get your own facts correct before making any comments about other peoples ability and knowledge, or all that happens is that YOU end up looking like an inexperienced, unknowledgeable idiot.
    Davepm your show that your lacking enormous amount of experience. How will i or noema access the internet channel if we don't upgrade to 4.2, your probably going to write an immature comment saying "you can update the the shop channel through wad manger". It makes me angry when people like you think they know everything. I dont want to start an augment like you (calling people an idiot make's you look like a rude and unsociable person) I know what i'm doing unlike some people, I softmod Wii's for a living you know. I'm just trying to help people not call them IDIOTS!!

  13. #10
    Senior Member
    Retired Staff
    davepm's Avatar
    Join Date
    Aug 2009
    Location
    Lincoln, Lincolnshire, United Kingdom
    Posts
    4,561
    Thanks
    124
    Thanked 2,059 Times in 831 Posts
    Blog Entries
    1
    Quote Originally Posted by Andy9702 View Post
    Davepm your show that your lacking enormous amount of experience. How will i or noema access the internet channel if we don't upgrade to 4.2, your probably going to write an immature comment saying "you can update the the shop channel through wad manger". It makes me angry when people like you think they know everything. I dont want to start an augment like you (calling people an idiot make's you look like a rude and unsociable person) I know what i'm doing unlike some people, I softmod Wii's for a living you know. I'm just trying to help people not call them IDIOTS!!
    in what way would that be an immature comment?

    I have 4.1

    Everything works. INCLUDING The internet channel.

    Ill say it again, THERE IS NO NEED TO UPDATE TO 4.2.

    You really do have no idea, do you?

    Maybe you should take some time out to read some of the forum, you might learn something.

    Please point out where i say i know everything? Im quite happy to tell people when i don't know the answer to their questions.
    Last edited by davepm; 11-29-2009 at 04:00 AM.

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •