I've been out of the game a while. I haven't done much at all with cIOS'. And i have some questions.

I'm still at 3.2U, Are there any good reasons to upgrade/stay?
For cios all i've tried was installing "IOS38-64-v3610". It seemed to work.
And neogamma says at the bottom "IOS249 (rev 14)". Is that right?
It doesnt seem to work though. Conflicting with my modchip?
But im not here to ask about backups.
I'm just curious what my initial steps should be to catch up on all this?

Without sifting through pages of unorganized confusion that i would get out of searching for it.
Please and thank you