Quote Originally Posted by Zore View Post
So that will work for 4.0U, and LU64.

~ Zore
Well, it says 3.1 to 4.1 ANY Wii, so my guess would be yes.


Yes it will work on any wii except LU64/65 cannot downgrade.