Results 1 to 6 of 6

Thread: Wasabi DX and Firmware 4.3E

  1. #1
    New Member
    Join Date
    Jan 2011
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Wasabi DX and Firmware 4.3E

    I have a wasabi dx and am running 4.3E firmware which means I cannot run out of region games.

    If I downgrade my firmware to play out of region games does this mean that my out of region backups will work but some of my newer backups may not work, in other words do some backups require 4.3 to play?

    Is it likely that sometime in the future an update may be written for the DX to allow it to play out of region games on 4.3 firmware?

  2. #2
    Senior Member Cile's Avatar
    Join Date
    Nov 2009
    Location
    Australia
    Posts
    5,071
    Thanks
    666
    Thanked 2,303 Times in 1,226 Posts
    Blog Entries
    9
    games don't depend on the system menu

    if you install an ios the game uses/needs it will work.....

    You need to downgrade to 4.1....http://www.wiihacks.com/game-playing...-4-3-wiis.html

  3. #3
    New Member
    Join Date
    Jan 2011
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Cile View Post
    games don't depend on the system menu

    if you install an ios the game uses/needs it will work.....

    You need to downgrade to 4.1....http://www.wiihacks.com/game-playing...-4-3-wiis.html
    Thank you for the prompt reply.

    I am knew to this, what do you mean by "install an ios the game uses"

  4. #4

  5. #5
    New Member
    Join Date
    Jan 2011
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you for the information.

    So if you put a disc in and it says there are updates is it just trying to update the ios if required and it is not trying to update the Firmware version of the wii.

    The wasabix DX says it has an update blocker built into the configuration, what type of update is it blocking?

  6. #6
    New Member
    Join Date
    Jan 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yup, I don't get it either.
    What is the update blocker blocking?

    I have a Wasabi dx running firmware 3.0 with the update blocker enabled. I tried a new backup copy of a game in recently and it gave me the 'update required' thing so I updated it. So what's been updated and what's been blocked? Is it the Wii firmware or just the IOS required for that particular game? The Wii is on firmware 4.2E and the multi region support still works on the Wasabi. I assume if I update the Wii firmware I'll be limited to PAL, Is that right?

    Thanks,
    Dave

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •