Hi people
I am very new to this so please forgive me if I am asking a question that has been asked before but I am not quite sure what im supposed to look for!

I got in the post today 2 wasabi dx mod chips which i installed on 2 wii's one was 3.2e and the other 3.4e.
Everything seemed to be working fine on both machines untill i tried to play a back up game called hasbro family nights on the machine that was on 3.2e.
The game worked fine on the 3.4 system but when i tried on the 3.2 it said it needs to update.
This is where the problem began after reading through some posts it seemed like it would be fine so i updated.
After I updated the system the 3.2 went to 3.4 and would not play the game!
BUT it works fine in the system that was originally 3.4.

All i would like to know is why I cant play this game now and what if anything I can do about it?

Would be really grateful if anybody can help me out here.
Thanks in advance
choppy