Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Wii dead after touching contact behind Power Button ...

  1. #1
    Roc
    Roc is offline
    Junior Member
    Join Date
    Sep 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Wii dead after touching contact behind Power Button ...

    While my wii was disassembled, I tried to power it on by pressing the power button with a screwdriver but I slipped just slightly and barely made contact with the metal behind the plastic button. I suspect the screwdriver may have also contacted the led and short circuited. The wii will not turn on anymore ... it's just dead.

    Has this happened to anybody else? Any suggestions on how to troubleshot/fix or is it toast?

  2. #2
    Member Dark Mod's Avatar
    Join Date
    Sep 2008
    Location
    Trinidad W.I
    Posts
    686
    Thanks
    0
    Thanked 11 Times in 10 Posts
    Quote Originally Posted by Roc View Post
    While my wii was disassembled, I tried to power it on by pressing the power button with a screwdriver but I slipped just slightly and barely made contact with the metal behind the plastic button. I suspect the screwdriver may have also contacted the led and short circuited. The wii will not turn on anymore ... it's just dead.

    Has this happened to anybody else? Any suggestions on how to troubleshot/fix or is it toast?
    hmmmmm.....looks like the motherboard gets slightly damaged. PM me for an offer.
    Thanks everyone for the great support.
    Hope to hear from you soon, cause i'm getting ready to retire from the modding scene.
    Gonna start a new profession.

  3. #3
    Reading Room
    Join Date
    May 2008
    Posts
    414
    Thanks
    0
    Thanked 1 Time in 1 Post
    its your power supply fuse...we have had this happen before and you just need to replace the power supply. they are very cheap around $20 online

  4. #4
    Roc
    Roc is offline
    Junior Member
    Join Date
    Sep 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks Gmodz. The power supply fuse you're referring to ... is it a fuse in the ac adapter on the power cord or is it a part on the Wii mobo?

    If it's on the Wii, do you know where I can find the steps to access it / replace it?

  5. #5
    Roc
    Roc is offline
    Junior Member
    Join Date
    Sep 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Wii power supply - problem solved

    Gmodz put me on the right track. After googling power supply issues, I found a Nintendo troubleshooting site. Turns out the Wii power supply has an internal reset ... just unplug for 90 seconds. I did this and the power came back.

  6. #6
    Reading Room
    Join Date
    May 2008
    Posts
    414
    Thanks
    0
    Thanked 1 Time in 1 Post
    glad to see you got it going! the dead power supply we got was completely dead and we had to open it up and replace the fuse

  7. #7
    Wiihacks Recommended
    Pro Installer/Store
    Senior Member
    Spyman's Avatar
    Join Date
    Jun 2008
    Location
    Greater Toronto Area
    Posts
    1,546
    Thanks
    33
    Thanked 123 Times in 106 Posts
    lol , we've seen this happen so many times on the forums, it sure is a scare. most the time just unplugging it does the trick, sometimes the fuse would need to be changed, either way its no big deal , but scary at first !
    Send me a PM if you need any Canadamods.ca support

    $9.95 Flat Rate Shipping to Canada & USA
    Official Support for Canadamods. I am here to help.

    email: sales@canadamods.ca | website: http://www.canadamods.ca | Phone: +1 416 728 0648

    We are the Official Distributors for: P.3Key, Wode JukeBox, WasabiDX, WiiKey, DriveKey, M3i & More - Always Authentic Guarenteed !
    Buy Wode JukeBox v2.0 here: Here

  8. #8
    Member
    Retired Staff Member

    Join Date
    Jun 2008
    Posts
    1,494
    Thanks
    70
    Thanked 230 Times in 116 Posts
    Wow, what a simple solution to a scary problem. Thanks for posting the solution.

  9. #9
    Junior Member
    Join Date
    Mar 2009
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thank a lot guys, for the great tip about this 90 secs unplugging. I was scared to death that my WII was bricked, but it came alive after the 90 secs waiting.

  10. #10
    New Member
    Join Date
    Jun 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yeah thanks alot, I was just working the kinks out of my wiikey and went to shut off the console, missed the button and bridged something with the screwdriver, I thought that was the end of my Wii

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •