Moosehead, this will definitely work with wasabi v1-3 as well. What's causing the problem is the system software, so this fix just corrects it by updating certain files without updating the whole thing to a version of the system software you might not want. You should avoid system software 4.2 espescially if you can! The fix I wrote about keeps your system at 3.2 while giving you support for new games.