Page 1 of 25 12311 ... LastLast
Results 1 to 10 of 241

Thread: So your Rock Band instruments won't work?

  1. #1
    Member trekster's Avatar
    Join Date
    Nov 2008
    Location
    Australia
    Posts
    2,188
    Thanks
    53
    Thanked 883 Times in 404 Posts
    Blog Entries
    2

    So your Rock Band instruments won't work?

    Rock Band 2 Tutorial on how to get your instruments running


    Firstly with this tutorial you will need an internet connection to your wii. If you don't have one then this wont work for you, So you better go and sort that out first


    Secondly if you don't have homebrew channel installed then don't even bother reading this, You will need homebrew channel so if you don't have it, go get it!



    Now, Download this for starters
    ciosinstaller.zip - File Shared from Box.net - Free Online File Storage


    You will notice the zip file is in the correct structure for you to just extract and copy it over to your sd card, I made the folders apps\ciosinstaller\

    I also put the boot.dol all ready for you =D


    Once that is done, Jump on the wii and fire up homebrew channel.


    Now, Navigate your sd card till you find the "ciosinstaller" and load it, When it loads you will be greeted by a black screen with white writing, It should look like this:





    You now need to use the d-pad, to change the selection of the cios that is about to be installed, You need to change it to install

    Custom IOS37 with IOS36 rev7 dip as IOS249


    once you've got it to that, Go ahead and install it, It will download the necessary files off the net and install them, Once thats done reboot the wii and play RB2 with instruments!


    Also here is a movie showing me load the program and select a few of the available options to give you an idea of what there is.... (The name I used on my card was different but its the same installer )


    You don't really need to watch it, but it might help some

    ciosinstaller.wmv - File Shared from Box.net - Free Online File Storage




    * NOTE: *

    If you have this all installed on 3.2 and the drums work, When you upgrade to 4.0 through the homebrew update thats floating around, Then the drums WILL NO LONGER WORK!!!!!!!! One way I've seen to get past this is to find "softchip" It will allow you to boot with cios37 which will allow the instruments to work, Other then that there is a thread on wiihacks about downgrading cios which might allow you to then reinstall cios37 as cios36 and use gamma launcher as normal.......

    There are posts saying that you need to install cios37 as 232 and do it that way, I haven't tried that, but I'm sure that it works.


    For users on later firmwares 4.0+ please go to this thread, download the multio cios installer and installer IOS37 as 232 and boot softchip using cIOS 232,

    will give you the same support from instruments you need

    http://www.wiihacks.com/recommended-...o-5-guide.html
    Last edited by trekster; 12-24-2009 at 12:38 PM.


  2. #2
    Junior Member
    Join Date
    Jan 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have a rockband track pack volume two game and guitar hero world tour instruments, will this help, or do you have a way to get it to work? I burned Rockband 2 and the Guitars work, not sure about drums, but only vocals show up on trackpack 2.

  3. #3
    Member trekster's Avatar
    Join Date
    Nov 2008
    Location
    Australia
    Posts
    2,188
    Thanks
    53
    Thanked 883 Times in 404 Posts
    Blog Entries
    2
    you can try but I dont know the compatibility for GH instruments and the RB1 expansion track packs, I don't know if the drums will work either, Try them on RB2 and see, They may only work on it and no the earlier games.

  4. #4
    Junior Member superredsoxfan7's Avatar
    Join Date
    Jan 2009
    Posts
    26
    Thanks
    8
    Thanked 3 Times in 3 Posts
    I can download all the files but when it begins to make a tile and gives me an error and then it will load me back to the homebrew channel. ive it with a cios and no cios but i cant get to work.

  5. #5
    Junior Member
    Join Date
    Jan 2009
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    what is the d- pad?

  6. #6
    Senior Member admiral victorinox's Avatar
    Join Date
    Apr 2008
    Location
    michigan
    Posts
    4,940
    Thanks
    1
    Thanked 2,603 Times in 873 Posts
    the up down left right thing

  7. #7
    New Member at90s2313's Avatar
    Join Date
    May 2008
    Location
    USA
    Posts
    177
    Thanks
    12
    Thanked 28 Times in 25 Posts
    Quote Originally Posted by TimDogg34 View Post
    I have a rockband track pack volume two game and guitar hero world tour instruments, will this help, or do you have a way to get it to work? I burned Rockband 2 and the Guitars work, not sure about drums, but only vocals show up on trackpack 2.

    I am pretty sure the GH:WT guitar will not work with the Rock Band 1 based games. I had read somewhere only the Rock Band 2 based games like the ACDC track pack will work with World Tour instruments. However 3rd party guitars might work with all the above. I don't have a 3rd party guitar so I don't know.

  8. #8
    Junior Member
    Join Date
    Jan 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Us Rock Band Instruments

    I have a Japanese Wii version 3.2J with Homebrew Channel. I followed your IOS36 rev7 dip as IOS249 instructions to the T, and used the newest version of Menu Loader, downloaded from Wii Brew, to load Rock Band 1 and 2 (store bought US discs) using IOS249 in Region Free mode. The discs won't load. I can load them and play them with Gecko OS, but the instruments won't work (except for microphone). I've scoured the web. I guess I'll just wait for a bit to see if a new version of Gecko OS comes out with a fix to this prob or just buy a US Wii.

  9. #9
    Member trekster's Avatar
    Join Date
    Nov 2008
    Location
    Australia
    Posts
    2,188
    Thanks
    53
    Thanked 883 Times in 404 Posts
    Blog Entries
    2
    Quote Originally Posted by coult45usmc View Post
    I have a Japanese Wii version 3.2J with Homebrew Channel. I followed your IOS36 rev7 dip as IOS249 instructions to the T,
    Did you select ios37 with ios36 ?

    Theres a few options in there, Also probably unrelated but have you tried loading it through gamma backup loader?

  10. 1 User Says Thank You trekster For This Useful Post


  11. #10
    Junior Member
    Join Date
    Jan 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yes, I installed ios37 with ios36, and I made sure to run media loader with ios249. I also tried gamma backup loader, still no joy...

Page 1 of 25 12311 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •