Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45

Thread: Tutorial: Customizing a Wii Theme

  1. #21
    New Member fiire's Avatar
    Join Date
    Jun 2010
    Location
    Chicago, IL
    Posts
    235
    Thanks
    16
    Thanked 76 Times in 55 Posts
    wrong line, your entry deals with the texture coordinates, and I honeslty have no idea what texture is in application to a picture.... It will be the "Push_US_ENG" entry towards the bottom. It's the same place where you can change the dimensions to make it widescreen.


    <tag type="pic1" name="Push_US_ENG" userdata="">
    <visible>01</visible>
    <WidescreenAffected>00</WidescreenAffected>
    <flag>00</flag>
    <origin x="Center" y="Bottom" />
    <alpha>ff</alpha>
    <padding>00</padding>
    <translate>
    <x>-0.00000000000000000000</x>
    <y>-255.00000000000000000000</y>
    <z>0.00000000000000000000</z>
    </translate>
    <rotate>
    <x>0.00000000000000000000</x>
    <y>0.00000000000000000000</y>
    <z>0.00000000000000000000</z>
    </rotate>
    <scale>
    <x>1.0000000000</x>
    <y>1.0000000000</y>
    </scale>
    <size>
    <width>800.000000</width>
    <height>450.000000</height>


    |4.1U|Bootmii/boot2|Priiloader v.04|
    |Wiiflow 2.1 Forwarder|Triiforce MRC SS USB Forwarder|VBAgx v2.0.08|WiiMC v1.0.6|


    Create your own custom system menu theme



    IF YOU FOUND MY POST HELPFUL, PLEASE REMEMBER TO CLICK THANKS!


  2. #22
    Retired WiiHacks Staff Krafter's Avatar
    Join Date
    Dec 2009
    Posts
    4,426
    Thanks
    460
    Thanked 1,093 Times in 857 Posts
    Blog Entries
    5
    Quote Originally Posted by fiire View Post
    wrong line, your entry deals with the texture coordinates, and I honeslty have no idea what texture is in application to a picture.... It will be the "Push_US_ENG" entry towards the bottom. It's the same place where you can change the dimensions to make it widescreen.

    If I understaind it right, "Push_US_ENG" is a container and "it_Has_b_US_ENG.tpl" is the texture of that container.
    Last edited by Krafter; 09-13-2010 at 05:42 AM. Reason: FIXED QUOTE.

  3. #23
    New Member Copjones1994's Avatar
    Join Date
    Sep 2009
    Posts
    25
    Thanks
    3
    Thanked 0 Times in 0 Posts
    <tag type="pic1" name="Push_US_ENG">
    <flags>01-07</flags>
    <alpha>ff-00</alpha>
    <coords>
    <x>-0.00000000000000000000</x>
    <y>61.00000000000000000000</y>
    <z>0.00000000000000000000</z>
    </coords>
    <flip>
    <x>0.000000</x>
    <y>0.000000</y>
    </flip>
    <rotate>0.000000</rotate>
    <zoom>
    <x>1.0000000000</x>
    <y>1.0000000000</y>
    </zoom>
    <size>
    <width>608.000000</width>
    <height>88.000000</height>
    </size>
    <material name="Push_US_ENG" />
    <colors>
    <vtx>0XFFFFFFFF</vtx>
    <vtx>0XFFFFFFFF</vtx>
    <vtx>0XFFFFFFFF</vtx>
    <vtx>0XFFFFFFFF</vtx>
    </colors>
    <coordinates>
    <set>
    <coord>0.000000</coord>
    <coord>0.000000</coord>
    <coord>1.000000</coord>
    <coord>0.000000</coord>
    <coord>0.000000</coord>
    <coord>1.000000</coord>
    <coord>1.000000</coord>
    <coord>1.000000</coord>
    </set>

    Here is the section pertaining to the push section for english usa

    and here is my MYM.ini file. mym.ini Can somebody take a look and see what im doin wrong? Ask to see anything else if you think you can help.

  4. #24
    New Member scottytaz's Avatar
    Join Date
    Mar 2010
    Posts
    18
    Thanks
    12
    Thanked 1 Time in 1 Post
    great thread managed to make a taz theme but then i downloaded the predator theme and used this as a start point for an ice age theme but evrytime i run my menu iget a fatal error ash unpack failed on both of these themes any help in resolving this would be much appreciated thank you in advance

    have managed to make a theme based on zelda for ice age but originally i downloaded predator theme and used that as the basis for an ice age theme but every time i run mymenu i get a fatal error ASH unpack fail any help in clearing this up would be very much appreciated many thnx for the guide

    ive just downloaded predator theme and using it as a base i made an ice age theme but when i try to run mymenu i get a fatal error ash unpack failed so i downloaded mymenu 1.3 and now i get a u8 upack failed please help many thanks in advance

  5. #25
    New Member fiire's Avatar
    Join Date
    Jun 2010
    Location
    Chicago, IL
    Posts
    235
    Thanks
    16
    Thanked 76 Times in 55 Posts
    @copjones: that is still the wrong spot as far as I can tell. It has nothing to do with your mym.ini. If you like, you can upload your brlyt/xmlyt, I'll change the numbers and then upload it for you....Keep trying though. If one spot doesn't work, just try another.

    @scottytaz: It sounds like mymenu is having trouble with an ash file, most likely board.ash. I'm guessing that you are not packing correctly with U8Tool. Again, you could send me the mym file and I'll try and fix it for you.


    |4.1U|Bootmii/boot2|Priiloader v.04|
    |Wiiflow 2.1 Forwarder|Triiforce MRC SS USB Forwarder|VBAgx v2.0.08|WiiMC v1.0.6|


    Create your own custom system menu theme



    IF YOU FOUND MY POST HELPFUL, PLEASE REMEMBER TO CLICK THANKS!


  6. #26
    Retired WiiHacks Staff Krafter's Avatar
    Join Date
    Dec 2009
    Posts
    4,426
    Thanks
    460
    Thanked 1,093 Times in 857 Posts
    Blog Entries
    5
    Quote Originally Posted by fiire View Post
    @copjones: that is still the wrong spot as far as I can tell. It has nothing to do with your mym.ini. If you like, you can upload your brlyt/xmlyt, I'll change the numbers and then upload it for you....Keep trying though. If one spot doesn't work, just try another.
    One tool I find handy is Notepad++. It's a free programmers text editor. It has some really nice features such as language selection and a built in comparator. I found it much easier to read the xmlyt files by changing the language to XML and also comparing files. You said in your first post that you had a theme that changed the position of the it_has_b_US.tpl/png. You can compare that themes it_has_a.brlyt/xmlyt file with an unaltered one to see what was changed and then tweak on it from there.

  7. #27
    New Member scottytaz's Avatar
    Join Date
    Mar 2010
    Posts
    18
    Thanks
    12
    Thanked 1 Time in 1 Post
    Quote Originally Posted by fiire View Post
    @copjones: that is still the wrong spot as far as I can tell. It has nothing to do with your mym.ini. If you like, you can upload your brlyt/xmlyt, I'll change the numbers and then upload it for you....Keep trying though. If one spot doesn't work, just try another.

    @scottytaz: It sounds like mymenu is having trouble with an ash file, most likely board.ash. I'm guessing that you are not packing correctly with U8Tool. Again, you could send me the mym file and I'll try and fix it for you.

    thannks for the reply but it doesnt matter now cos my wii hhas bannerbricked itself it did this a few times but i managed to unbrick it by removing the theme and running priloader but thir time preloader and bootmii are not there so basically im screwed as i was running 4.2 e unless youknow of anyway roundd it thanks again

  8. #28
    New Member fiire's Avatar
    Join Date
    Jun 2010
    Location
    Chicago, IL
    Posts
    235
    Thanks
    16
    Thanked 76 Times in 55 Posts
    that sucks, scottytaz. Sorry, but it sounds like this brick issue beyond my knowledge. I know Krafter ran into a similar problem, but he was lucky with bootmii/boot2. I would mention something in the brick section, but be prepared to be yelled at because you were messing around with themes.

    What message shows up? If you can get past the health/safety screen and there are NO words, then that means that your message board is screwed up. You can get past that by holding the +/- buttons at the health/safety screen, but again that is only if you do not get the "the system menu files are corrupt" message.


    |4.1U|Bootmii/boot2|Priiloader v.04|
    |Wiiflow 2.1 Forwarder|Triiforce MRC SS USB Forwarder|VBAgx v2.0.08|WiiMC v1.0.6|


    Create your own custom system menu theme



    IF YOU FOUND MY POST HELPFUL, PLEASE REMEMBER TO CLICK THANKS!


  9. #29
    New Member Copjones1994's Avatar
    Join Date
    Sep 2009
    Posts
    25
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Ok here is my it has BRLYT. it_Has_a.brlyt.xmlyt

  10. #30
    New Member fiire's Avatar
    Join Date
    Jun 2010
    Location
    Chicago, IL
    Posts
    235
    Thanks
    16
    Thanked 76 Times in 55 Posts
    huh....your xmlyt is different than mine. What are your region and system menu? I am NTSC-U 4.1 and my xmlyt files match up with those over at wiibrew. I mean I'm able to understand yours, but you seem to be missing some lines, and others are referenced differently. I never would have imagined that a different system menu version would change the brlyts!!!! Because now that I look at it, you guessed correctly your second time, but the <translate> header is not present, nor are your originating positions.......did you use my version of benzin, or did you compile it yourself? I guess I could pm you a link to my it_Has_b.brlyt with y = 61, but you need to reassure me that you have boot2 installed, especially if you have a different system menu version than me.


    |4.1U|Bootmii/boot2|Priiloader v.04|
    |Wiiflow 2.1 Forwarder|Triiforce MRC SS USB Forwarder|VBAgx v2.0.08|WiiMC v1.0.6|


    Create your own custom system menu theme



    IF YOU FOUND MY POST HELPFUL, PLEASE REMEMBER TO CLICK THANKS!


Page 3 of 5 FirstFirst 12345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •