Results 1 to 3 of 3

Thread: Long delay before getting to game list USB GX and CFG

  1. #1
    New Member
    Join Date
    Nov 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Long delay before getting to game list USB GX and CFG

    Hi to everyone, this place has been very interesting and helpful but now I need to step out of the shadows and ask something..

    I've found a few threads dealing with freezing when opening a USB loader which seem resolved with a removal and reinsert after starting the app.
    My (less than major) issues however, are:
    1. When starting the Wii (from yellow or red light) and running USB loader GX, CFG loader and WiiMC there is a long (65-70 seconds) where GX "Initialise USB", CFG pauses on load screen for same amount of time (and loses controller sync), and WiiMC takes just as long before the USB option appears. Now the odd thing is once I've been in a program and it eventually loads, I can exit and enter almost immediately just like my USB HDD (2-3 seconds), This continues until resetting, standby, or off. Games load perfectly as does media in WiiMC, its just a little annoying and makes me wonder if I can rectify it or if I missed something.

    2.Also if my HDD (which loads both GX/CFG perfectly) is connected when launching Homebrew browser it crashes to an ISI exception and crashes to a DSI exception in WiiMC. This may be a compatibility issue as its a 1TB iomega USB3(not on the compat. list)  3 equal partitions first is primary active fat32, the others are primary NTFS. But as i said it runs the loaders perfectly.
    I'm running 4.3E on an older Wii and followed Mauifrog's (sic? I foget his name, sorry) very good guide found on WiiHacks.
    Now back to the first issue, ths USB drive is also not on the compatibility list either. It's a LEXAR 64GB Echo MX. The only thing special(read: possibly problematic!) is that it has an e-ink capacity meter and had a mysterious 49MB unallocated space at the beginning, while the rest was FAT32 primary active. I formatted the whole thing using HP formatter just to see if it would help but no change, I've also tried NTFS and even WBFS, All work fine in the above mentioned apps aside from that initial delay. Interestingly, even after removing the 49MB the meter still works (except on WBFS of course)

    Update: While typing this I was reformatting to FAT32 again and have now noticed it ALWAYS has the 65-70 second delay regardless of rebooting the Wii or not and NOW WiiMC doesn't have any delay whatsoever (1-2 seconds for USB to appear) Other USB flash drives work fine, so it maybe compatibility but why then would it work after trying for over a minute? The 65(GX)-70(CFG) seconds is pretty much like clockwork, never less or more so what the hell is it trying to do in that minute?

    I have also tried inserting the USB when USB loader GX starts the 20 second search countdown but it freezes instantly on 19 seconds (or whatever number its on) for a long time until it changes to -100 seconds or -60 seconds etc then freezes more before finally giving up at not finding anything - so appears to be a different issue to the remove and insert fix.

    Thoughts anyone, if its simply compatibility I'd be interested to hear what goes on in that 65 second handshake if possible. Thank you
    Sorry if its a long read but I just wanted you to know I've tried lots of things already.
    Last edited by dragon934; 11-30-2011 at 04:29 AM.

  2. #2
    Senior Member Shift_Lock's Avatar
    Join Date
    Dec 2010
    Location
    The City of Rain
    Posts
    5,932
    Thanks
    1,320
    Thanked 1,389 Times in 1,030 Posts
    Blog Entries
    2
    It probably IS a compatibility thing. stick to 2.0 USB's.. the 3.0 have compatibility issues.

    Did I come off like a jerk?? Read more here


    [/spoiler]

  3. #3
    New Member
    Join Date
    Nov 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Sorry, I made such a wall of text I wasn't clear...

    The USB Flash drive IS a USB 2.0, it's my HDD that has 3.0 . The delay only occurs with the Flash drive. Would this be a problem with compatibility too?

    It just seems it isn't happy and crashes. It was only by accident I found out it takes 65 secs when I left it on while doing something else only for it to come alive and act like nothing was ever wrong.
    It's turned more into a quest for infomation now rather than a fix, as I will get a compatible flash drive next week (kids cant be trusted with a HDD - not that they're that cheap anyway at the moment lol)
    I'm noobing my way through learning about the Wii at the moment, so if anyone can explain what would take 65 seconds to complete a handshake I'd appreciate it.

    ****Edit****
    From what I've learned so far (very little) the only thing I can think is that WiiMC must use a different CIOS (or is it IOS) and that GX and CFG must be on the same (C?)IOS. Assuming I'm correct what IOS should i use. (still havent quite got the whole 249 of base xx thing yet.) If I'm totally out then please tell me... I dont want to change anything unnecessary as I know the Wii is fine with other H/W. But if anyone thinks a change can work, by all means encourage me on
    Last edited by dragon934; 11-30-2011 at 08:14 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •