Results 1 to 7 of 7

Thread: USB Corruption Issue

  1. #1

    USB Corruption Issue

    I've had a hacked Wii for a fair while now, originally it was using a Seagate 500gb USB drive to run 1 partition WBFS (Using USBLoader GX), 1 FAT32 for emulators, Mighty Channels and the like. This worked absolutely fine, until I an emergency with my PC and needed to formate the USB drive and used it as a NTFS one, after backing everything up. Once I restored it back to how it was (WBFS, FAT32), the WBFS partition was working fine, but whenever I tried to load anything up from the FAT32 partition, it would either crash (Mighty Channels) or when loading USB, would show corrupted folders, using Wingdings like text (SNES9X GX for example). The drive worked absolutely fine on Windows, no sign of corruption and could shift everything about. After doing a few formats and reloading the backups to make sure, I reformatted and tried to use a clean drive and make new folders for the emulators. Same problem.

    This week, I thought maybe the WBFS partition was the issue, so reformatted the whole drive again, this time making it a full FAT32 drive with a WBFS folder. Now it gets really confusing. USBLoader GX can see the WBFS games on the FAT32 drive fine and run them without issue BUT when you look at the remaining drive space, it says "0.00GB of 0.00GB used", so obviously somethings wrong there, and I still have the same issues with everything else.

    I've just run through the Softmod ANY Wii guide to see if somewhere down the line I'd mucked up something, but still no joy. As its quite an old Wii that was hacked a fair while ago, numerous bits and pieces have been bolted on following guides from here, but I was wondering if anyone had any experience with this problem or knew that I had installed something I shouldn't have thats blown it?

    EDIT: Because I'm a muppet it never occurred to me to test with a USB stick or another drive (Mainly because this is the only USB External drive I own). Just tested on a USB stick and its working fine, folders are picked up in SNES9XGX and I can load up a rom no problem, which means its not down to the Wii. Still why would a USB drive that formerly worked in FAT32 suddenly corrupt ONLY on the Wii, but still allow me to load WBFS files fine? Any ideas?
    Last edited by Angel Abaddon; 01-07-2012 at 05:04 AM.

  2. #2
    WiiHacks Staff
    Only Site Donators Can PM Staff
    playerkp420's Avatar
    Join Date
    Jan 2010
    Have you tried going with just one fat32 partition? There is a guide in the spoiler below. Worth a shot. IDK?

  3. #3
    Thanks for the reply, but unfortunately I have tried it as just one big FAT32 drive previously, following that guide in fact. Its what I'm currently trying to get the Wii to pick up properly. I'm now wondering if the formatting is what made things go wonky. I usually use EASEUS Partition Master after seeing it recommended here and a few other places. I'm giving the Command Prompt a run through, using the "format /fs fat32" command. Its been running for a few hours, whereas EASEUS did a quick format.

  4. #4
    And I think I've figured out the problem, if not the solution. With none of the emulators working, but USBLoaderGX working fine, I loaded up WiiMC (installed along with the softmod guide) to see what that showed. Turns out, the drive has TWO partitions according to the Wii. USB WII (The actual partition I've made) and USB MASS STORAGE (2). This second one doesn't actually show up under Windows or any form of partition management. Does ANYONE have any experience with Seagate drives have any clue whats happening here?

  5. #5

  6. #6
    Theres not a WBFS partition on it any more, and when it did, its still showed up under Windows as unformatted space. Right now it is showing under Windows Management and EASEUS as 1 single FAT32 drive. The only place I can see this second "ghost" partition is WiiMC. I'm assuming that the emulators are all reading that but the real partition is still visible to the Wii as WBFS files are loading off the FAT32 drive (as in, inside a wbfs folder on the FAT32 partition) and I've installed WiiXplorer and it has no issue seeing the proper partition (but can't see this "ghost" one at all).

  7. #7
    And fixed. In case anyone comes up against a similar issue, I ended up fixing it by using DISKPART (inside command prompt) and the CLEAN command on the disk itself. Weird that only certain parts of the Wii could access this hidden drive (Emulators, Homebrew Browser and WiiMC could access it, but WiiXplorer couldn't see it), and no application in Windows could see it, but it was there as Homebrew Browser ended up writing data (temp folder) to it. But alls well that ends well I guess.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts