Results 1 to 3 of 3

Thread: skylanders - unable to read disk

  1. #1

    skylanders - unable to read disk

    So the boy got skylanders for christmas and the wii is modded with the "Guide: Softmod ANY Wii" from the recommend FAQ section.

    The wii will not recognize the disc either from the Disc Channel or the USBLoaderCFG both say "Unable to read the disc" we did take the disc to grandmas un-modded wii and it worked fine.

    Now I had modded this wii some time ago and the boy managed to bork it up so I had to re-mod and after that we were able to play all the games I had on the usb hard drive.

    I just tested a couple other disc's and I get the same error... "Unable to read the disc"

    any ideas. is the drive toast? any help would be much appreciated.

    Thanks in advance

  2. #2
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Pob3008's Avatar
    Join Date
    Nov 2009
    Sounds like the drive is dead

  3. #3
    I got unable to read disc error with skylanders upon my softmod wii. Disc update option has been disabled.

    I put the same disc in another not softmodded wii and the wii asked for a firmware update. Once update completed successfully then skylanders played fine in my not softmodded wii.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts