I searched a lot on the web and also on this website, and found nothing like my situation yet. I also consulted and followed step by step to the best of my knowledge the softmod any wii guide and red_gh0st's thread on Skyward Sword.

Here's my situation:

1) I have a retail copy of LoZ:SS

2) Problem: blackscreen when I leave the first building (the double doors to go outside once you get out of Link's bedroom)

3) Restored the wii to its former state (first backup you do when you softmod)

4) Upgraded to 4.3 via Nintendo. Still doesn't work. same blackscreen.

5) Softmodded again via Softmod ANY wii guide. Installed cios 249[56]d2x v6 and 250[57]d2x v6. Still same blackscreen.

6) Formatted my HD to Fat32 and created a wbfs image from my Collector's Edition retail disc using USBLoaderGX

7) Loaded the game with USBLoaderGX with ios 248, with ios 249, with ios 250, and with ios 222 blocking ios reload. It all failed at the same spot : the moment I leave the first building to get outside.

8) I tried loading with Wiiflow. Failed too.

9) Converted my retail version to an iso with my friend's wii (to check if the laser was the problem) and then to wbfs using Wii Backup Manager Build 76. Transfered on my Fat32 USB Drive and loaded with Cfg Usb Loader. Tried with ios 248 and ios 249.

My disc is working. I went to my friend's house tonight and I saw for the first time what was beyond those damn double doors....

Can someone help me? Is the only solution left to virginize my wii?
I think the problem comes from the first time I softmodded, since I had bugs sometimes in other games too. Those were randoms though. Like Donkey Kong, it was suddenly freezing with a buzz sound.
But this is the first time with Zelda where it always freezes at the same spot.

Here is my syscheck report:


Thank you very much for your help!