Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Thomas Hero of the rails

  1. #1

    Thomas Hero of the rails

    My Wii is from North America so I think NTSC and softmodded with the letest and greatest.

    I bought this game from Ebay I think it is PAL. I used the built in transfer in the USB loader and transferred the .wbfs files the hard drive. When I start it in the USB loader it just loads to a black screen and stays there. Is there some setting I need to set. I bought Bob The Builder from Ebay, did the same thing and it worked great, it was also PAL.

    Any Ideas?

  2. #2
    WiiHacks Staff
    Only Site Donators Can PM Staff
    playerkp420's Avatar
    Join Date
    Jan 2010
    Force ntsc in the game settings of your loader. Also, enable priiloader hack region free, if you have priiloader.

  3. #3
    Thanks for the advice. I have looked everywhere and can't seem to find where to change those settings.

  4. #4

    what CIOS and USB GX settings?

    Anyone have Thomas & Friends working on their NTSC wii? I had this working previously when using the older version of USB Loader GX but in order to play newer games like Smurfs off the USB drive I had to update to the newer version of GX and apply the d2x CIOS v2.2 for CIOS 249 and 250. I had read somewhere that the game would work on Hermes CIOS 222 v4. I manually installed CIOS 222 base 38 and 223 base 37 merged 38 and tried selecting those in GX but no luck.

    If anyone is able to play Thomas & Friends from a USB loader, please let me know what loader you are using and its settings and what CIOS you have loaded.



  5. #5
    Quote Originally Posted by wwweeesss View Post
    If anyone is able to play Thomas & Friends from a USB loader, please let me know what loader you are using and its settings and what CIOS you have loaded.
    I got this working. I left the hermes v4 cios 222 and 223 loaded and then downloaded uloader 5.1. It plays the game perfectly fine, but man I really hate the uloader app compared to usb gx. It is very slow to load the game list a page at a time and the middle finger icon isn't exactly what I want my kid looking at. I don't know why usb gx won't work with cios222 selected, hopefully it is something that will get fixed later.

  6. #6

    I just got it on GX!

    The setting that made the difference on USB Loader GX was VIDEO MODE = DISC DEFAULT. Other settings such as SYSTEM DEFAULT, FORCE NTSC, FORCE NTSC-480p, etc will merit the black screen with wiimotes unsynced. This is on 4.3U NTSC wii.

    For the longest time, I had it working in CFG, multiple versions up to v70, with both 249r21 and 249d2x. Which cIOS you use isn't the stopper. On this PAL Hero of the Rails, after fighting it for months, I discovered the Video method was the trick. (just tonight!) I do have my priiloader set to region-free-everything, but i'm not sure if that is a contributing factor. (if it ain't broke......) Best of Luck!

  7. #7
    Setting the video mode to disc default didn't fix my problem. If I try cIOS 222 it still gives me the black screen but I can hear audio cutting in and out and feel the remote rumble. I am on 4.3U NTSC as well but am not using priiloader. Maybe some other setting needs changing. Can you post what your GXGameSettings.cfg line is for this game?

    game:ST4PNX = video:0; language:10; ocarina:0; vipatch:0; ios:222; parentalcontrol:0; errorfix002:2; iosreloadblock:0; patchcountrystrings:0; loadalternatedol:0; alternatedolstart:0; alternatedolname:; returnTo:1; sneekVideoPatch:0; NandEmuMode:-1; Hooktype:-1; WiirdDebugger:-1; Locked:0;

  8. #8

    My settings in more detail

    Here is the section of my settings that coincides with what you posted. I can tell by looking that you're using an older version of usbloadergx. I can also tell you have a language selected in your game file though I don't know which one. Try defaulting this setting. I have also discovered the hard way that some titles like the newer Kirby Dreamland REQUIRE default language.... If you FORCE english (on an english game), it freezes a white screen after credits.

    Try making sure you have or find a USBLoaderGX version TWO-point-whatever, then do the online update via global settings menu. My credits screen reflects version 2.3 as most current version at this posting. The "-1"s below reflect "Use Global" from the game settings. Example ios:-1 means to use whatever the loader uses, no custom setting for the game, or for me, to use cIOS 249. Here's my stats in detail:

    NTSC 4.3u (smashstacked)
    priiloader 0.7 -region free everything enabled
    GX loads on cIOS 249D2x(m56)

    game:ST4PNX = video:1; language:-1; ocarina:-1; vipatch:-1; ios:-1; parentalcontrol:0; errorfix002:1; iosreloadblock:2; patchcountrystrings:-1; loadalternatedol:4; alternatedolstart:0; alternatedolname:; returnTo:1; sneekVideoPatch:-1; NandEmuMode:-1; Hooktype:-1; WiirdDebugger:-1; Locked:0;

    GX global menu LOADER SETTINGS I use (see file pasted below):

    Video mode FORCE NTSC
    VIDTV patch OFF
    Sneek Video Patch OFF
    Game Language CONSOLE DEFAULT
    Patch Country Strings ON
    Ocarina OFF
    Boot/Standard 249
    Quick Boot OFF
    Error 002 Fix ANTI
    Block IOS Reload AUTO
    Return To USB LOADER GX
    NAND Emulation OFF
    Hooktype NONE
    WIIRD Debugger OFF
    Debugger Paused Start OFF

    Hard Drive Settings
    Multiple Partition Mode
    No File Splitting
    2TB Seagate GoFlex Desk... stable for a year.

    This is my GXGlobal.cfg text-pasted below. If you copy this to try it, you'll want to set your cover paths back to your own preferences. Parental control code is 1234 and setup only for childproofing. I do force english by default just for smiles and grins, and if a game doesn't work, I'll tinker with video patches first, language next.

    Again, Good Luck!

    # USB Loader GX R1123 - Main settings file
    # Note: This file is automatically generated
    godmode = 1
    videomode = 4
    videopatch = 0
    language = 10
    ocarina = 0
    hddinfo = 1
    sinfo = 1
    rumble = 1
    volume = 80
    sfxvolume = 80
    gamesoundvolume = 80
    tooltips = 1
    RememberUnlock = 1
    password = 64617178
    GameSort = 1
    cios = 249
    keyset = 0
    xflip = 2
    gridRows = 1
    quickboot = 0
    wsprompt = 0
    parentalcontrol = 4
    covers_path = sd:/WBFSM4Images/IMAGES/3D/
    covers2d_path = sd:/WBFSM4Images/IMAGES/2D/
    coversFull_path = sd:/WBFSM4Images/IMAGES/FULL/
    theme_path = sd:/apps/usbloader_gx/theme/
    theme =
    disc_path = sd:/WBFSM4Images/IMAGES/DISC/
    language_path = sd:/apps/usbloader_gx/language//english.lang
    languagefiles_path = sd:/apps/usbloader_gx/language/
    TxtCheatcodespath = sd:/txtcodes/
    titlestxt_path = sd:/apps/usbloader_gx/
    gamesound = 1
    dolpath = sd:/
    ogg_path =
    wiilight = 1
    gameDisplay = 1
    update_path = sd:/apps/usbloader_gx/
    homebrewapps_path = sd:/apps/
    Cheatcodespath = sd:/codes/
    BcaCodepath = sd:/bca/
    WipCodepath = sd:/wip/
    WDMpath = sd:/wdm/
    titlesOverride = 0
    patchcountrystrings = 1
    screensaver = 3
    musicloopmode = 1
    error002 = 2
    autonetwork = 0
    discart = 0
    partition = 0
    marknewtitles = 1
    ShowFreeSpace = 0
    InstallToDir = 2
    GameSplit = 0
    InstallPartitions = FFFFFFFE
    PlaylogUpdate = 1
    ParentalBlocks = FFF7DDBE
    returnTo = 554e454f
    HomeMenu = 2
    MultiplePartitions = 1
    USBPort = 0
    CacheTitles = 0
    BlockIOSReload = 2
    WSFactor = 0.800
    FontScaleFactor = 0.800
    EnabledCategories = 0
    Wiinnertag = 0
    WiinnertagPath = sd:/apps/usbloader_gx/
    SelectedGame = -2
    GameListOffset = 1
    sneekVideoPatch = 0
    NandEmuMode = 0
    NandEmuPath = sd:/nand/
    UseSystemFont = 1
    Hooktype = 0
    WiirdDebugger = 0
    WiirdDebuggerPause = 0
    ShowPlayCount = 1

  9. #9
    Oh yeah, I noticed from Sept 13 that your D2x was v2.2. I'm using v6's on 248-250. Hope this info below helps as well if you're still having a hard time.
    I just ran this syscheck for reference. This config keeps most things simple. Load GX loader on 249. most games including microphone game work on 249. Use 223 when the mic doesn't respond. Guitar Hero guitars respond on 249. Call of Duty's work on 250. Spongebob boating bash on 247. With Block IOS Reload setting on AUTO, most things just simply work right the first time. Try around pending your issue.

    When I started last year, GX was my "go-to" loader. When CFG introduced eyecandy gui's, I swapped as there was of course the fact that I could get Thomas to load in CFG when It wouldn't load in GX. When GX got themes working again, and via snazzy theme loader (though I lost prior downloaded theme use) and started d2x support, i was sold back to GX. It's simpler to tie down parental controls per each setting to keep it stable, unbotched, and still allow updates, cover downloads, category use, etc while locked.

    sysCheck v2.1.0b14 by Double_A and R2-D2199
    ...runs on IOS58 (rev 6176).

    Region: NTSC-U
    System Menu 4.3U (v513)
    Priilaoder installed
    The drive doesn't support DVDs
    Homebrew Channel 1.0.8 running on IOS58
    Hollywood v0x21
    Console ID: 131089350
    Boot2 v4
    Found 434 titles.
    Found 45 IOS on this console. 4 of them are stub.

    IOS3 (rev 65280): Stub
    IOS4 (rev 65280): Stub
    IOS9 (rev 54321): Trucha Bug
    IOS10 (rev 768): Stub
    IOS11 (rev 54321): Trucha Bug
    IOS12 (rev 269): No Patches
    IOS13 (rev 273): No Patches
    IOS14 (rev 520): No Patches
    IOS15 (rev 523): No Patches
    IOS16 (rev 54321): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS17 (rev 775): No Patches
    IOS20 (rev 54321): Trucha Bug
    IOS21 (rev 782): No Patches
    IOS22 (rev 1037): No Patches
    IOS28 (rev 1550): No Patches
    IOS30 (rev 54321): Trucha Bug
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3091): No Patches
    IOS34 (rev 3348): No Patches
    IOS35 (rev 3349): No Patches
    IOS36 (rev 54321): Trucha Bug, ES Identify, NAND Access
    IOS37 (rev 3869): No Patches
    IOS38 (rev 3867): No Patches
    IOS50 (rev 54321): Trucha Bug
    IOS51 (rev 4864): Stub
    IOS53 (rev 5406): No Patches
    IOS55 (rev 5406): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5661): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 54321): Trucha Bug
    IOS61 (rev 5405): No Patches
    IOS70 (rev 54321): Trucha Bug
    IOS80 (rev 54321): Trucha Bug
    IOS90 (rev 54321): Trucha Bug
    IOS202[60] (rev 65535, Info: hermes-v5.1): Trucha Bug, NAND Access, USB 2.0
    IOS222[38] (rev 65535, Info: hermes-v5.1): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223[38] (rev 4, Info: hermes-v4.0): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS224[37] (rev 65535, Info: hermes-v5.1): Trucha Bug, NAND Access, USB 2.0
    IOS236 (rev 54321): Trucha Bug, ES Identify, NAND Access
    IOS247 (rev 65535): Trucha Bug, NAND Access, USB 2.0
    IOS248[57] (rev 21006, Info: d2x-v6): Trucha Bug, NAND Access, USB 2.0
    IOS249[56] (rev 21006, Info: d2x-v6): Trucha Bug, NAND Access, USB 2.0
    IOS250[58] (rev 21006, Info: d2x-v6): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v65535

    Report generated on 2011/11/29.

  10. #10
    Quote Originally Posted by skipaaa View Post
    Here is the section of my settings that coincides with what you posted. I can tell by looking that you're using an older version of usbloadergx.
    Actually I am using 2.3 r1131 which I compiled just 2 weeks ago. About once a month I download the latest source code and compile it rather than waiting for releases. I'll first try changing my game load settings to match yours and see if that works. I've done some IOS updates in the last month so I'll have to check my sysinfo against what you show below, thanks a lot for that. I am loading GX on 249, and I think its D2x-v6. I need to check 222, it may be hermes 4.x.

    Hopefully I'll have time to work on this tomorrow, I'll post back my results.

Page 1 of 2 12 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts