I'm getting a black screen when trying to load games through wiiflow 2.1. I have softmodded a few consoles and this is the first time I've got this problem. Any help would be greatly appreciated.
Wii was originally hardmodded with drivekey(solderless), this has been removed prior to sofftmod. Firmware was 2.1e, I updated this to 3.1e using Lego indiana jones original adventures. Installed homebrew using bootmii V0.8. Installed waninkokos 249, 250, hermes 202,222,223. Installed patched ios60 and updated to 4.1e via wad manager. installed cios249(57)v20wad and cios250(37)v20wad. Installed priloader and blocked online and disc updates.
All of this I have done a few times before with no problems. With this particular wii, the games all show up on the hdd but when i go to launch a game it freezes on a black screen. The hdd is fat32 formatted, all games are in wbfs format and were transferred across using wii backup manager.
What I've tried so far:
tried the hdd on another softmodded unit and it worked fine
tried another know good hdd with the problem wii, same problem occured so its not the hdd.
deleted wiiflow.ini and reloaded, no change
reloaded all ios/cios, no change

this same setup has worked for me on a few other units so I'm at a loss as to why this units is giving problems. I have the original nand dump so I can reset and start again but I'd like to avoid that if i can. I would be greatful for any suggestions. Cheers.