Results 1 to 9 of 9

Thread: SNES9x GX cover mod problem

  1. #1

    SNES9x GX cover mod problem - "USB device not found"

    Hi everyone

    This is my first post here, and I am fairly new to the homebrew community. I've been trying to install both the SNES9X GX 4.1.5.c.3 Cover Mod and the FCE Ultra GX 3.1.3 Cover Mod, both found on this site. The problem is I get a message "USB device not found" when I indicate that I want to lead games from my usb device.

    Things I have tried:

    1-Install the supported updated versions (both found on this site) *This worked, USB works fine and I can load games, but of course, no covers

    2-Completely format both my SD and USB cards (Fat32), re-install everything (including cover mod emulators) *Did not work, USB device not found. Again, when I install the supported version, the usb works fine

    Any help would be greatly appreciated. Thank you.
    Last edited by leojreimroc; 02-15-2011 at 01:22 PM. Reason: Clarified Title

  2. #2
    Member
    Retired WiiHacks Staff
    Darkcide666's Avatar
    Join Date
    Jan 2010
    Location
    Upstate NY
    Posts
    3,719
    I know my answer is the simplest and the one you dont want to hear but I suggest use the official ones. The cover mods are missing some imporant updates. I played around with the cover mod emulators for a while but I'll take necisarry improvements and bug fixes over a cover loading GUI any day.
    "Hackers solve problems and build things, and they believe in freedom and voluntary mutual help." - Eric S. Raymond

  3. #3
    You're probably right. However, if anyone knows a fix for my initial problem, it would still be great to know why it wouldn't recognize my usb. I would still like to play around with the cover mod. Depending on what kinds of bugs there were in the older version, it might be a trade-off that I'd be willing to make.

  4. #4
    Member
    Retired WiiHacks Staff
    Darkcide666's Avatar
    Join Date
    Jan 2010
    Location
    Upstate NY
    Posts
    3,719
    When you look over the changelogs of the official versions a lot of improvements have to do with USB loading. The third change down of the most recent 4.2.5 update of Snes9x and 3.2.3 update of FCE Ultra GX is "Improved USB compatibility and speed". Maybe your drive will never work with the cover mod versions. Here is a full list of all of the fixes and improvements you are missing:

    [SPOILER="Snes9x"]
    4.2.5 - October 7, 2010

    * Sync with upstream SVN - fixes a few specific game issues
    * Fixed "blank listing" issue for SMB
    * Improved USB compatibility and speed
    * Added Portuguese and Brazilian Portuguese translations
    * Other minor changes

    4.2.4 - August 14, 2010

    * IOS 202 support removed
    * USB 2.0 support via IOS 58 added - requires that IOS58 be pre-installed
    * DVD support via AHBPROT - requires latest HBC

    4.2.3 - July 22, 2010

    * Fixed broken auto-update

    4.2.2 - July 20, 2010

    * Reverted USB2 changes
    * Fixed return-to-menu crash with Filtered mode

    4.2.1 - July 14, 2010

    * Improved audio timing
    * Fixed 16:9 correction in Original mode
    * Ability to use both USB ports (requires updated IOS 202 - WARNING: older versions of IOS 202 are NO LONGER supported)
    * Fixed issue with IPS patch files
    * Hide non-ROM files
    * Other minor improvements

    4.2.0 - June 20, 2010

    * Fixed incorrect aspect ratio issue
    * Fixed choppy framerate issue
    * Fixed IPS/UPS patching
    * USB improvements
    * GameCube improvements - audio, SD Gecko, show thumbnails for saves
    * Other minor changes

    4.1.9 - May 19, 2010

    * DVD support fixed
    * Fixed some cheats issues
    * Fixed some potential hangs when returning to menu
    * Video/audio code changes
    * Fixed scrolling text bug
    * Other minor changes

    4.1.8 - April 9, 2010

    * Fix auto-save bug

    4.1.7 - April 9, 2010

    * Freezing issue fixed
    * Core timing fixes, should solve some problems with some games
    * Most 3rd party controllers should work now (you're welcome!)
    * 7z crash fixed
    * GameCube only - DVD/SD Gecko fixed (thanks emukidid!)
    * Translation updates (German and Dutch)
    * Other minor changes

    4.1.6 - March 30, 2010

    * New core! Updated to Snes9x 1.52. Old save states will not work!
    * DVD / USB 2.0 support via IOS 202. DVDx support has been dropped. It is highly recommended to install IOS 202 via the included installer
    * Multi-language support (only French translation is fully complete)
    * Thank you to everyone who submitted translations
    * SMB improvements/bug fixes
    * Minor video & input performance optimizations
    * Now uses .srm files without "Auto" appended, if found
    * Added option to disable crosshair [/SPOILER]

    [SPOILER="FCE Ultra GX"]3.2.3 - October 7, 2010

    * Sync with upstream SVN - fixes a few specific game issues
    * Fixed "blank listing" issue for SMB
    * Improved USB compatibility and speed
    * Added Portuguese and Brazilian Portuguese translations
    * Channel updated (improved USB compatibility)
    * Other minor changes

    3.2.2 - August 14, 2010

    * IOS 202 support removed
    * USB 2.0 support via IOS 58 added - requires that IOS58 be pre-installed
    * DVD support via AHBPROT - requires latest HBC

    3.2.1 - July 22, 2010

    * Fixed broken auto-update

    3.2.0 - July 20, 2010

    * Reverted USB2 changes

    3.1.9 - July 14, 2010

    * Fixed 16:9 correction in Original mode
    * Fixed PAL/NTSC timing switching issue
    * Ability to use both USB ports (requires updated IOS 202 - WARNING: older versions of IOS 202 are NO LONGER supported)
    * Hide non-ROM files
    * Other minor improvements

    3.1.8 - June 20, 2010

    * USB improvements
    * GameCube improvements - audio, SD Gecko, show thumbnails for saves
    * Other minor changes

    3.1.7 - May 19, 2010

    * DVD support fixed
    * PAL/NTSC timing corrections
    * Fixed some potential hangs when returning to menu
    * Video/audio code changes
    * Fixed scrolling text bug
    * Other minor changes

    3.1.6 - April 9, 2010

    * Fix auto-save bug

    3.1.5 - April 9, 2010

    * Most 3rd party controllers should work now (you're welcome!)
    * Translation updates (German and Dutch)
    * Other minor changes

    3.1.4 - March 30, 2010

    * DVD / USB 2.0 support via IOS 202. DVDx support has been dropped. It is highly recommended to install IOS 202 via the included installer
    * Multi-language support (only French translation is fully complete)
    * Thank you to everyone who submitted translations
    * SMB improvements/bug fixes
    * Minor video & input performance optimizations
    * Synced with official FCEUX (various game fixes)
    * ROMs larger than 3 MB now load
    * Now also searches in application path for gg.rom and disksys.rom [/SPOILER]

    Both base versions for the cover mods are well over a year old.
    "Hackers solve problems and build things, and they believe in freedom and voluntary mutual help." - Eric S. Raymond

  5. #5
    Thanks for posting those. I had seen those changes before however in one of your earlier posts (I believe in the cover mod thread in these forums). So yeah, I was aware that highly probable that the version is just too old to currently work with my current setup.

    Although I'm it works for somebody, so I was hoping for a solution anyways. It can't hurt to ask. I do have the 4.2.5 version running now though, so at least I can still play games. I would still like to try the cover modded one though. Maybe if I try to get a hold of an old usb key?
    Last edited by leojreimroc; 02-16-2011 at 06:41 AM.

  6. #6
    Member
    Retired WiiHacks Staff
    Darkcide666's Avatar
    Join Date
    Jan 2010
    Location
    Upstate NY
    Posts
    3,719
    The only way I can think of the might work would be to build and compile from source yourself.
    "Hackers solve problems and build things, and they believe in freedom and voluntary mutual help." - Eric S. Raymond

  7. #7
    Chances are, if I had the ability to do that, I wouldn't have made this thread heh. I'm wondering if other people also had this problem, if so, if they managed to find a fix.

  8. #8

    Snes9x Cover MOD USB2 MOD

    I Made this usb2 mod last year maybe you could give it a try !

    You need hermes CIOS 202 for USB2 function.

    Snes9xGX Cover USB2 + classic controller MOD


    Quote Originally Posted by leojreimroc View Post
    Hi everyone

    This is my first post here, and I am fairly new to the homebrew community. I've been trying to install both the SNES9X GX 4.1.5.c.3 Cover Mod and the FCE Ultra GX 3.1.3 Cover Mod, both found on this site. The problem is I get a message "USB device not found" when I indicate that I want to lead games from my usb device.

    Things I have tried:

    1-Install the supported updated versions (both found on this site) *This worked, USB works fine and I can load games, but of course, no covers

    2-Completely format both my SD and USB cards (Fat32), re-install everything (including cover mod emulators) *Did not work, USB device not found. Again, when I install the supported version, the usb works fine

    Any help would be greatly appreciated. Thank you.

  9. #9
    Thanks for the advice. I'll try that soon-ish. I still haven't mooded any CIOS in my wii yet. The guide that's on here suggests to downgrade to 4.1 which I'm still unsure if I want to do or not. (I'm on 4.3). Gonna do a bit more reading on it, but I'll post on here when I get to try the version that you posted.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •