I'm having a problem with running any USB Loaded backups. Everything worked fine until my Wii was accidentally upgraded to 4.2. I've been trying to get the cIOSes back to working ever since but I'm at my wits end here. Recently I tried using the YAWM Multimod but it returned in an error -1 for every wad it tried installing (tried installing with IOS 236, 249, and 250). I'm assuming that one of my cIOSes is corrupt or old but it really isn't allowing me to upgrade. This is what Syscheck returns:

Found 40 IOS on this console. 9 of them are stub.

IOS4 (rev 65280): Stub
IOS9 (rev 778): No Patches
IOS10 (rev 768): Stub
IOS11 (rev 256): Stub
IOS12 (rev 269): No Patches
IOS13 (rev 273): No Patches
IOS14 (rev 520): No Patches
IOS15 (rev 523): No Patches
IOS16 (rev 512): Stub
IOS17 (rev 775): No Patches
IOS20 (rev 256): Stub
IOS21 (rev 782): No Patches
IOS22 (rev 1037): No Patches
IOS28 (rev 1550): No Patches
IOS30 (rev 2816): Stub
IOS31 (rev 3349): No Patches
IOS33 (rev 3091): No Patches
IOS34 (rev 3348): No Patches
IOS35 (rev 3349): No Patches
IOS36 (rev 3351): Trucha Bug
IOS37 (rev 3869): No Patches
IOS38 (rev 3867): No Patches
IOS50 (rev 5120): Stub
IOS51 (rev 4864): Stub
IOS53 (rev 5406): No Patches
IOS55 (rev 5406): No Patches
IOS56 (rev 5405): Trucha Bug
IOS57 (rev 5661): No Patches
IOS58 (rev 6175): No Patches
IOS60 (rev 6400): Stub
IOS61 (rev 5405): No Patches
IOS70 (rev 6687): Trucha Bug
IOS202 (rev 65535): Trucha Bug
IOS222 (rev 65535): Trucha Bug
IOS223 (rev 65535): Trucha Bug
IOS224 (rev 65535): Trucha Bug
IOS236 (rev 65535): Trucha Bug
IOS249 (rev 20): Trucha Bug
IOS250 (rev 20): Trucha Bug
IOS254 (rev 65281): BootMii
BC v6
MIOS v10

Report generated on 2011/01/13.

Also, this Wii has worked fine with my external HDD before. I've run backups and videos without any problems. The backups haven't been working since the upgrade to 4.2, yet the videos ran without any problem but recently Mplayer CE has been stopping playback of videos about 5 minutes in. I assume this has to do with my attempts to update the IOSes. I'm using the current Neogamma to play backups, as well as the Configurable USB Loader, and my HDD is a 1 TB WD MyBook. Any ideas?