*Note: originally posted in "emulators download" section, not sure why it was there. Creating new thread here in hopes of getting more help.

Quote Originally Posted by roadofexcess View Post
mine works with hbc 1.0.8 from harddrive. you could try reinstalling mame. or just keep 1.0.5
After reverting back to HBC 1.0.5 (I had reverted back to an earlier version of the HBC because MAME works in it), I soon decided to go back to 1.0.8 (because of the HBC update alert constantly popping up) -- it also just felt weird not being on the latest rev. Of course, since switching back to HBCv.08, MAME no longer boots up again. I tried my luck at reinstalling the HBC with IOS 58 v6176 (was previously on IOS 61); it's great that there's now USB2.0 functionality and quicker loads, but still no luck with MAME properly booting up. I've tried replacing the boot file and restoring the default config files in the MAME folder; I even tried re-downloading the MAME emulator via the Homebrew Browser - but still nothing. I'm usually one to figure things out, but this is just a head-scratcher and frankly, it's starting to piss me off

I've just tried reinstalling HBC 1.0.8 a third time, because I read somewhere that if one were to install IOS58 after the fact, reinstalling the HBC is recommend -- MAME still does not work, however.