Newbie here.
I was trying to soft mod my wii following the instructions from this thread: I have modded the wii before and it worked out fine, but wanted to play the newer games so I thought I would start from the beginning.

This time I was following the instructions and I got to the point to downgrade the 'IOS15' but it wouldn't work. I saw a post within the thread saying that if it was previously modded or was version 4.1 then to skip steps 3a-c, so I did. I got distracted and skipped to step 5 (priiloader install) before I did the cIOS38 r17 install in step 3d. So I ran the cIOS38 r17 install hoping it would work out ok. Continued onto step 5a, but Priiloader said that the Homebrew Channel was not working/not installed. Tried to access Homebrew from the System menu but when I clicked start the screen would turn black and music would be playing.

And now nothig works, I can get into the home screen but none of the channels work, can't access the sd card from the wii options, and if I try to get into priiloader by pressing reset before power it will load for a few seconds and then go back to the system menu. It won't even read original discs, it'll either show the two discs spinning while trying to read it or a few times it'll say it's the wrong format.

PLEASE HELP! I have searched to see if there was anything similar and there have been but none of those solutions have worked for me yet.