Results 1 to 5 of 5

Thread: Can't save SRAM on any emulators

  1. #1

    Can't save SRAM on any emulators

    Hey y'all, first time posting on here but have been reading it since xmas when I got my first Wii system. I've been into modding and emulators a good portion of my life so I can usually figure out what I'm doing, but this time I'm stumped. Have been searching and reading all I can in the post archives and can't find the answer, so I figured I'd register and ask myself.

    The emulators are working great other than none of them will save. I've already made sure that the directory exists (/snes9xgx/saves for snes9x and /vbagx/saves for vba, etc). I am loading roms off a USB hard drive, and trying to save onto an SD Card. Accordingly, in the emulator save/load options it is set to Load from the USB and Save to the SD.

    The card is not locked, and has space on it. Also the emulators will take snapshots fine but when I try to save in vbagx for example, it says "no data to save" if I remember right.

    One other thing, with snes9xgx it appears to save but then when I load the game, it just resets. Not sure if it is actually saving the file and just not loading, or if there is a problem with saving. Or both.

    Any help is appreciated.. and it's good to be a member of another forum!

    UPDATE: FCEU works fine when I choose to Save State, but when I want to Save RAM it says "No data to save!" just like snes9x gx and vbagx both do.

    SECOND UPDATE: Genesis Plus GX appears to save and load just fine too. So maybe I exaggerated a little by saying "any emulators", but I am still having the same problem with snes9x and vgagx!

    THIRD UPDATE: I found out that in both emulators, if I choose to Save Snapshot it not only saves a snapshot, but a save file as well. Then when I go to load, I click on the snapshot and it loads the corresponding state. Works fine for me, an interesting bug but at least I can save! I'm curious as to why it's not more common.
    Last edited by mozzles; 12-30-2010 at 11:10 PM.

  2. #2
    Introduce Yourself

    And look at the two sticky threads in this section from DarkCide. After FULLY READING and if issues, inquire within whichever thread is relevant to your question.

  3. #3
    Retired WiiHacks Staff
    Darkcide666's Avatar
    Join Date
    Jan 2010
    Upstate NY
    I don't know if because you are loading off of one device and saving to another has something to do with it? I know it's a dumb question but have you tried only using one yet?
    "Hackers solve problems and build things, and they believe in freedom and voluntary mutual help." - Eric S. Raymond

  4. #4
    Not a dumb question, I was actually thinking the same thing. I've read that there shouldn't be a problem with loading roms off one device and using another for saves, but just in case last night I set it to save to USB as well as load, still no luck.

    And thanks nightstah, I've read those posts and about everything else I can find on here pertaining to my issue. Rather than resurrecting an old thread I thought it'd be best to start my own.

  5. #5

    Unhappy More SNES9XGX saving problems,

    Hello everyone!

    I'm having a similar issue and haven't been able to find a solution on the forum. I'm loading and saving
    to a SD card and the files are set up correctly (emulator in apps, roms/saves on the root). But when I
    go to save I get a 'error directory can't be found' message and sometimes this happens when I go back
    to my roms list. Would anyone have a solution?



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts