Results 1 to 4 of 4

Thread: Should i update my wii past 3.4?

  1. #1

    Should i update my wii past 3.4?

    Currently i have a wii with firmware 3.4 and i was wondering if i softmod it will i still be able to play all the new games? And if so can i run the games off my external HD? also any guides you guys know will work, if you could send them that would be great! Preferably video guides. Thanks guys!

  2. #2
    Member WhiteShad0wX's Avatar
    Join Date
    Jun 2010
    Location
    I'm right here
    Posts
    1,615
    DON'T UPDATE!
    4.2 and 4.3 were only released to stop homebrew. Follow the softmod any wii guide (link in my signature). It'll update you to 4.1
    Once you do that, you can update individual IOS's and such on your wii to run the newer games.
    All wii's can run games off of an external usb drive
    See the Thanks button over there?
    <================================= Click it

  3. #3
    New Member worzel gummidge's Avatar
    Join Date
    May 2010
    Location
    A field somewhere
    Posts
    69
    I am still on 3.2 and can run all games everyone else can. U dont need to update if you dont want to. Only reason to update would be able to use sdhc cards. And have nice sd card icon on your menu.


  4. #4
    Member
    Retired WiiHacks Staff
    Darkcide666's Avatar
    Join Date
    Jan 2010
    Location
    Upstate NY
    Posts
    3,719
    Quote Originally Posted by worzel gummidge View Post
    Only reason to update would be able to use sdhc cards. And have nice sd card icon on your menu.
    And be able to launch WiiWare/VC from a SD/SDHC or download straight to it. But the more important reason to update to 4.1 seeing as the OP is on 3.4 now would be PriiLoader. Those were all of the reasons I updated from 3.4.
    "Hackers solve problems and build things, and they believe in freedom and voluntary mutual help." - Eric S. Raymond

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •