Results 1 to 3 of 3

Thread: sysCheck GX v1.0.0 by erikspyder

  1. #1
    Senior Member Cile's Avatar
    Join Date
    Nov 2009
    Location
    Australia
    Posts
    5,071
    Thanks
    666
    Thanked 2,303 Times in 1,226 Posts
    Blog Entries
    9

    sysCheck GX v1.0.0 by erikspyder

    This homebrew does several checks on installed IOS and custom IOS and generates a report on the root of the SD card.

    Features:
    * Nice GUI;
    * Report viewer;
    * Simplified / detailed report with information about what IOSes are and what they are useful for;
    * Language file;
    * Configurable settings;


    Download:Download sysCheckGX.rar, upload your files and earn money.

    [SPOILER=''PICS"]
    [/SPOILER]

    [SPOILER="info"]i like this one but could use improvement,here's the new look, it saves the report as .txt so open with wordpad or micro word and it will tell if you have priiloader installed one bug it display all cios with es identfy patch which is not correct and once you close the report your left with blank screen with a settings button which doesnt really have any really useful features

    sysCheck GX v1.0.0 by Erik Spyder

    sysCheck GX is running under IOS58 (rev 6175).

    Console ID: XXXXXXXX.
    Region: PAL.
    Hollywood v0x11.
    Boot2 v3.
    System Menu v450 (4.1E).
    BC v5.
    MIOS v9.


    Found 112 titles.
    Found 31 IOS on this console.
    No IOS Stub on this console!

    Priiloader is installed.


    IOS 9 (rev 1034)
    IOS 12 (rev 269)
    IOS 13 (rev 273)
    IOS 14 (rev 520)
    IOS 15 (rev 1032)
    IOS 17 (rev 775)
    IOS 21 (rev 1038)
    IOS 22 (rev 1037)
    IOS 28 (rev 1550)
    IOS 31 (rev 3349)
    IOS 33 (rev 3091)
    IOS 34 (rev 3348)
    IOS 35 (rev 3349)
    IOS 36 (rev 3351): Trucha Bug, ES_Identify, NAND Access
    IOS 37 (rev 3869)
    IOS 38 (rev 3867)
    IOS 53 (rev 5406)
    IOS 55 (rev 5406)
    IOS 56 (rev 5662)
    IOS 58 (rev 6175): USB 2.0
    IOS 60 (rev 6174): Trucha Bug
    IOS 61 (rev 5405)
    IOS222 (rev 4): Trucha Bug, ES_Identify, USB 2.0
    IOS223 (rev 65535): Trucha Bug, ES_Identify, NAND Access, USB 2.0
    IOS224 (rev 65535): Trucha Bug, ES_Identify, NAND Access, USB 2.0 (same base 57 so no es identfy patch)
    IOS236 (rev 65535): Trucha Bug, ES_Identify, NAND Access
    IOS247 (rev 20): Trucha Bug, ES_Identify, NAND Access ........(not detecting usb 2.0)
    IOS248 (rev 20): Trucha Bug, ES_Identify, NAND Access.........(not detecting usb 2.0 & its base 56 so no es identfy patch)
    IOS249 (rev 20): Trucha Bug, ES_Identify, NAND Access.........(not detecting usb 2.0 & its base 57 so no es identfy patch)
    IOS250 (rev 65535): Trucha Bug, ES_Identify, NAND Access.......(not detecting usb 2.0 & its base 37 so no es identfy patch)
    IOS254 (rev 65281)

    Report generated on 2010-11-02.



    [SPOILER="the other report that it saves"]sysCheck GX starting up...

    Getting the console region... Success.
    Getting the system menu version... Success.
    Getting the running IOS version and revision... Success.
    Getting the console ID... Success.
    Getting the boot2 version... Success.
    Getting number of titles... Found 112 titles.
    Getting list of titles... Success.
    Sorting titles... Success.
    Getting the certificates from the NAND... Success.

    Reloading IOS58 (rev 6175)... Success.

    Generating the report... Success.
    Mounting SD card... Success.
    Initializing the FAT File System... Success.
    Creating report to sd:/sysCheckGX.txt... Success.

    Report saved successfully.
    [/SPOILER][/SPOILER]
    Last edited by Cile; 11-02-2010 at 02:50 PM.

  2. 2 Users Say Thank You to Cile For This Useful Post


  3. #2
    Member WhiteShad0wX's Avatar
    Join Date
    Jun 2010
    Location
    I'm right here
    Posts
    1,615
    Thanks
    274
    Thanked 320 Times in 290 Posts
    thanks cile
    I want to try this out
    See the Thanks button over there?
    <================================= Click it

  4. #3
    New Member
    Join Date
    Oct 2010
    Posts
    11
    Thanks
    0
    Thanked 1 Time in 1 Post
    Generally worked good, thanks. Here are some suggestions.
    1. Let me change my report folder to usb. I tried usb:\ usb0:\ and usb1:\ and none seemed to work for the port I was in. Suggestions are welcome. I'm sure you already thought of this and there is some technical glitch. I'd love to hear what it is so i can learn.
    1a. Same thing, about the usb drive except have it check both SD AND USB for the config folder so it doesn't crash when it doesn't find it on the SD....maybe put up an error if you can't fix it such that someone knows they HAVE to put in the SD card.
    2. Put the config folder here: drive:\apps\syscheckGX\config so that your total apps folder is self contained. Why would i want a config folder off the root. Sure, i can fix it (i assume i didn't try) by changeing the path, but pre-fix it so no one else has to.
    3. Register this with homebrew browser.

    Otherwise, nice job. Thanks for your efforts!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •