Results 1 to 4 of 4

Thread: Sid Meiers Pirates! - cannot get past the spinning wheel

  1. #1

    Sid Meiers Pirates! - cannot get past the spinning wheel


    I have just recently followed the softmod guide here on my black 4.3e wii (PAL) and have homebrew and USB CFG loader (v60 with the recommend hermes 222/223/224 ios's) working great for around 12 of my wii games.

    However, nothing I try for Sid Meiers Pirates! (NTSC version) can get me past the "spinning wheel" loading screen, I have tried, ios 249, 222, 223, 224 with every combination of setting I could see.

    I have tried the Force Pal 60, region fix, and video fix etc.. but can never get past the spinning wheel

    Can anyone suggest something I could try?

    Many thanks!


  2. #2
    I have this problem too...
    I can play the game from the DVD, but my HDD backup copy dont work (using both wiiflow and usb loader)...

  3. #3
    I know this is extremely old...but ios 250 worked great for me. Hopefully someone like me will see this and save themselves a little frustration.

  4. #4


    Thanks for the advice, I tried ios 250 but it spits back a bunch of errors and resets the wii everytime I try it.

    I got desperate and tried a PAL version of the game, but still no luck (now running v65 USB Loader)




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts