Results 1 to 2 of 2

Thread: Disc Dumping with Modchips (Wasabi DX)

  1. #1
    Junior Member
    Join Date
    May 2008
    Thanked 0 Times in 0 Posts

    Disc Dumping with Modchips (Wasabi DX)


    Are there any known issues using the Wii to dump discs when having a modchip fitted please?.

    I recently logged another thread with a similar theme (See SSBB - "Error Reading Disc ID" - In this I was trying to dump a retail SSBB using SuperDump but it was failing to read the Disc ID. Similar issues were being shown with Gecko, USB Loader GX and NeoGamma, however the Disc Channel had no issues with the disc. Other retail discs could be dumped without issue.

    At the time I had a soldered mod-chip, which I believe to have been a Argon Clone.

    Later (mentioned later in the above thread), I had the soldered modchip removed. Without the modchip I could successfully dump SSBB without any issues.

    I've since installed a Wasabi DX, and note similar issues. I've was trying to dump a couple proper discs - Ghostbusters, Sega All-Stars Racing and even the supplied Wii-Sports (for testing purposes). In all cases SuperDump would slowly reveal the Disc ID, and then eventually give up with the error "Error reading sector data". However, a game already on stored on a DVD can be dumped without issue.

    I've tried with the Wasabi DX setting for Region Free and Update Blocking both on and off (and a mixture of these), as well as toggling the various Priiloader settings (Region Free, Update Blocking etc).

    The only way I managed to dump these discs was by disconnecting the Wasabi DX (ie Opening the cases, and connected the Mobo direct to the DVD Drive). Once this was done I could dump happily.

    I know that for some disk dumping is now old hat, and they would recommend using a USB Drive loader - such as USB Loader GX. However, even if I was to look at this I still face the same issue that I can't actually dump the discs. For example, USB Loader GX happily recognises that a disk has been inserted and will offer to install it (or run it), but after a short period of time will question whether the retail disc is even a Wii game.

    Wii Dump 1.5 will start, recognise the USB drive/SD card, and that a disc is present but will then crash the Wii (I think you reference it as a DSi - similar to a Windows BSOD).

    I've done numerous searches of GBAtemp, and Google for this type of issue, and "Error reading sector data" and can't seem to find any of references to this type of issue, thus I'm wondering if I'm doing, or have done at some other stage, something wrong.

    The Wii has no issues using these discs from the System Menu Disc Channel.

    Just wondering if anyone has any suggestions please.

    Configuration Information for the Wii is below.



    Running PAL 4.2E. Originally was a NTSC unit but I changed the region using ARC. Unit is coming up to be about 2 years old.

    SuperDump v1.3
    WiiDump v1.5
    USB Loaded GX
    cIOS 38 rev 17
    Priiloader installed with the Region Free hack
    Mod-Chip installed - Wasabi DX running 3.0 firmware

  2. #2
    New Member
    Join Date
    Aug 2009
    Thanked 0 Times in 0 Posts
    I had a similar issue to you, have you tried this:


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts