Results 1 to 8 of 8

Thread: MPlayer-Wii not reading DVDs

  1. #1

    MPlayer-Wii not reading DVDs

    Hi guys,

    Running 4.2E, hardmodded Wiikey1 and softmodded with DVDX installed.

    Trying to get Mplayer-Wii_rodries v. 0.07.4 r20 to read DivX files from the wii DVD drive. Works perfectly from SD and USB.

    When I press A on the DVD option the app spins the drive for a few seconds then opens up the browsing page with nothing listed there. Tried it on several DVDs, (all different kinds). And yes the files are real DivX .avi files that run from the USB or SD card perfectly, the DVDs work on my DVD player aswell.

    If I press A on the empty browsing page it will code dump and crash.

    I have run 'pimp my wii' and upgraded all IOS files.
    All other homebrew is working fine.

    Any advice at all would be appreciated!

  2. #2
    Can you play DVDR games from your drive?

    Try creating a DVDR with your divx files in directories (folders) and see if you can see the directories in mplayer, I have a feeling that you won't see them as you can't utilise DVDRs (ie your drive not seeing them)?

    It is much easier to stream from your PC to your Wii if you can go that route anyway? Saves plugging in & out and writing disks all the time, download and then watch straight away, much quicker too.
    Please remember your manners - say Thank You if someone helped , it doesn't hurt

  3. #3
    Yes I can play DVDR games from my drive, I only softmodded my wii a couple weeks ago and have just been runing off the wiikey for the past year or so.

    I already have so much of my TV already burnt to DVD and not on my computer anymore which is why I was hoping this would work. I will try burning the divx files in directories now

    edit: cant read directories on the dvd either
    Last edited by nathanpie1; 01-25-2010 at 05:43 PM. Reason: updated

  4. #4
    I'm not sure if DVDX installer will help you, you may wish to digest the readme:

    libdi and the DVDX installer.
    Please remember your manners - say Thank You if someone helped , it doesn't hurt

  5. #5
    Awesome, I can see the files now!
    I had to do the patchmii install for DVDX rather than the normal install.

    Problem is they don't play.

    Error -32: reading sectors xxxxxxxxx-->xxxxxxxxx

  6. #6
    Glad it worked

    Now remember that little thank you button :whistles:
    Please remember your manners - say Thank You if someone helped , it doesn't hurt

  7. #7
    Sorry, you only get half a thanks, i tried playing the files and they dont run, although they do appear now!

    edit: false alarm, reinstalled DVDx through patchmii and it works now.
    Now you earn your 3 internets, and a thanks!
    Last edited by nathanpie1; 01-25-2010 at 06:15 PM.

  8. #8
    please, can you tell me how you installed dvdx and from where you got it? I'm trying to use de dvdx installed by Hackmii installer, Mplayer works
    but if I install a wiikey later, I fear I'll have problem since when I installed DVDx with hackmii installer, it never asked me to use Patchmii or not

    thank you a lot, I did some search but am more confused


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts