Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Problem with transcend drive

  1. #1

    Problem with transcend drive

    I got a nice shiny new transcend storejet 25m 320gB drive from santa. thing is I can't get it formatted. I have tried WBFS manager 2.2.2 and 3.0.1. It's been formatted with windows to FAT32 and NTFS. Still no joy. I did try to format it with USB loader 1.5 but it would stack dump once it got to the press any key to continue screen. USB loader 1.5 seemed to work without errors but I unplugged it form the wii and into the laptop but WBFS still has the same error. "An error occurred, make sure the drive is not in use and formatted to WBFS." I can't think of anything else to try.

    Any suggestions?


  2. #2

    Same here

    Hi everyone,

    I too just bought a Transcend StoreJet 25M (320GB) specifically because it was described as working on various USB compatibility lists.

    Unfortunately I ran into the exact same problems as justsayin.

    On top of what has been written I can add that:
    - wbfs_win reports: 'error writing hd sector: No error'
    - Easeus Partition reports it as 'Unsupported Disk'

    Has anyone with this particular model managed to get it working?


  3. #3


    I did contact their tech support from their website and got n email right back and was told that my issue was being forwarded to Taipai. That was a couple weeks ago and I haven't heard anything else. I gave up on the drive and gave it to the wife for her junk. Now I got a WD MyBook 1TB

  4. #4
    Sorry to say that I think that this drive might need to be removed from the compatible drives list. Here's my story:

    I have exactly the same drive as listed above. The drive works flawlessly in Wndows and a full check of the drive shows no errors. In additional, I have USB Loader GX and USB Loader 1.1 working fine on the Wii using a memory stick. But, when I try to format the Transcend drive to WBFS using every one of the WBFS managers (I've tried all of them including doing a wbfs.exe d init from the command line), I get a variety of errors all relating to being unable to format the drive (no, I don't have UAC enabled in Vista and yes, the drive is powered on properly and I've tried pre-formatting it to FAT32, NTFS and leaving it as RAW). If I plug it into the Wii and try to use USB loader to format it, I get an error about the USB drive not being found. If I use USB Loader GX, I get the famous black screen. So, it all sounds like a classic case of an incompatible drive.

    If you read you'llsee that there are two users claiming that the Transcend StoreJet works fine but interestingly, one that says it doesn't. I'm going to PM them to get more information as something's not right here.
    Last edited by mossywell; 01-13-2010 at 09:01 AM.

  5. #5
    Hi guys, I think I've solved this problem =D

    I wrote to various Wii communities, but it seems that no one has an answer. My solution is based on expirements - I've tried almost all version of loaders and programs for pc. Now the drive works for loading ISOs, but still it has great problems in compatibility with other homebrew.

    So, I recommend you to use Wii Backup Manager for formatting & copying ISOs. Make partitions, and format partition for games in FAT32 firstly. Then format it in WBFS through WBM.

    To load games on Wii use USB Loader 1.5 & Neogamma (I'm using R7, works perfectly).

    As for other homebrew, most progs crash & even 202 doesn't help. Mplayer & Wiixplore do not work.

    Good luck & u'r welcome with questions.)

  6. #6
    @Shokolad: Nice one - I gave it a go and success! In fact I tried WBM before but missed one step which is why I thought it wasn't working. For anyone else trying to use WBM, here are the exact steps I did (you might be able to cut out one or two of them):
    - I had to connect both USB ports up (I think one just supplies extra power but I'm not sure).
    - Delete any partitions on the usb drive.
    - Create a new FAT32 partition in Windows and make a note of the drive letter you use.
    - Fire up Wii Backup Manager (I used 0.3.3).
    - Options, Settings, Drives and untick "use mounted volumes only" (This was the bit I missed before which meant that when I formatted it to WFBS, and later restarted WBFS, it could no longer see the drive, so I thought it wasn't working. D'oh!) This is essential if you later want to add backup ISOs to the drive without nuking the drive first.
    - Tools, Format drives... and select your drive. It should format OK.
    - Transfer your files. (Files, Add etc etc.)

    When it's done I connected it to the Wii (both USB ports again - don't know if that's really necessary), I could use either USB Loader 1.5 or Neogamma r8 beta 15 to get it working. Unfortunately, USB Loader GX (latest version - not tried earlier versions) just does the black screen trick which is unfortunate as it's my favourite usb loader!

    Anyway, thx Shokolad for putting in all the hard work and sharing the info.

  7. #7
    Hi guys,

    a followup on my story. I brought the drive back to the shop and asked for another one.
    As many people reported it as fully compatible and at least one person had my problem, I had a hunch that it could be a faulty batch or a revised production process. And as the S/N of the replacement drive was similar to the original one, I decided to try the 250GB version.

    So I brought back home a Transcend StoreJet 25M 250GB, plugged it in, and guess what? it works like a charm! games, mplayer, ... the works.

    Easeus Partition Master recognizes the new drive.
    This post states that "EASEUS Partition Master can only support the hard drive which is based on MBR". Does it mean there is no MBR on the 320GB (i.e. it cannot be used as a boot device)?
    Anyhow I downloaded a program called MbrFix and tried this approach. It failed, reporting an error with parameter 87 (if I remember correctly).

    If it can be of any help, the S/N of the faulty drive is 303736-0039

    best of luck.

  8. #8
    Quote Originally Posted by sebbino View Post
    Does it mean there is no MBR on the 320GB (i.e. it cannot be used as a boot device)?
    Interesting! Perhaps the 320 GB drives are set up as GPT and not MBR - it would explain both errors. Will check mine when I get home and if it's GPT will change it to MBR and see what happens.

  9. #9
    Update: not the drive is not GPT, it is MBR. But, I think I have found a difference. If I use HDDScan on the Transcend drive, I get:

    LBA Support Yes
    LBA28 268435455
    LBA48 625142448
    ATA Version 8
    Logical Sector Size 512 bytes
    Physical Sector Size 4096 bytes

    If I compare this with an older drive that works fine, I get:

    LBA Support Yes
    LBA28 268435455
    LBA48 976773168
    ATA Version 7
    Logical Sector Size 512 bytes
    Physical Sector Size 512 bytes

    Notice that the physical sector is 4096 not 512 bytes. 4096 is the new standard for hard drive physical sector size. I'd bet that the 250 GB Transcend drive has a 512 byte physical sector size. Here's an interesting article about the insides of WBFS: Inside WBFS - The problem is that it is a bit woolly when talking about "sector size". I think that most references of "sector size" are logical sector size not physical (in which case, the conversation isn't too relavant to this issue!).

    Anyway, if anyone feels like doing a hddscan (it doesn't write to the drive) on some drives and posting the results, we might be able to confirm that the wbfs managers (except wbfs backup manager) don't work with physical sectors greater than 512.

    I'm guessing / rambling by the way, so feel free to chip in.

  10. #10
    mossywell - I think you are correct. I ran hddscan on my 320GB transcend drive which works fine and found this:

    LBA Support Yes
    LBA28 268435455
    LBA48 625142448
    ATA Version 8
    Logical Sector Size 512 bytes
    Physical Sector Size 512 bytes

    Also - The transcend is identified by hddscan as a samsung HM320II.

    It appears Transcend (or their supplier) has quietly done what Western Digital had publicly announced: changed the drive to one with a Physical Sector Size of 4096 bytes.

Page 1 of 3 123 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts